aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2022-08-07 14:59:56 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-10 21:36:17 +0200
commit3986e7c1748c1d847ee4b7d3c9df73c7f0220969 (patch)
treea1c9cc521bd7231e4b2f11165f64768badde9648 /package/kernel/linux
parent5ccf4dcf8864c1d940b65067d8c6f7c4e5858ae2 (diff)
downloadupstream-3986e7c1748c1d847ee4b7d3c9df73c7f0220969.tar.gz
upstream-3986e7c1748c1d847ee4b7d3c9df73c7f0220969.tar.bz2
upstream-3986e7c1748c1d847ee4b7d3c9df73c7f0220969.zip
kernel: kmod-mdio-gpio: kmod-switch-rtl8366-smi: Add kmod-of-mdio dependency for malta
These two modules also need a depend to kmod-of-mdio on malta. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/netdevices.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 55b87ab13e..ffae986d5f 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -158,7 +158,7 @@ $(eval $(call KernelPackage,mdio-devres))
define KernelPackage/mdio-gpio
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:= Supports GPIO lib-based MDIO busses
- DEPENDS:=+kmod-libphy @GPIO_SUPPORT +(TARGET_armvirt||TARGET_bcm27xx_bcm2708||TARGET_tegra):kmod-of-mdio
+ DEPENDS:=+kmod-libphy @GPIO_SUPPORT +(TARGET_armvirt||TARGET_bcm27xx_bcm2708||TARGET_malta||TARGET_tegra):kmod-of-mdio
KCONFIG:= \
CONFIG_MDIO_BITBANG \
CONFIG_MDIO_GPIO
@@ -354,7 +354,7 @@ $(eval $(call KernelPackage,switch-rtl8306))
define KernelPackage/switch-rtl8366-smi
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Realtek RTL8366 SMI switch interface support
- DEPENDS:=@GPIO_SUPPORT +kmod-swconfig +(TARGET_armvirt||TARGET_bcm27xx_bcm2708||TARGET_tegra):kmod-of-mdio
+ DEPENDS:=@GPIO_SUPPORT +kmod-swconfig +(TARGET_armvirt||TARGET_bcm27xx_bcm2708||TARGET_malta||TARGET_tegra):kmod-of-mdio
KCONFIG:=CONFIG_RTL8366_SMI
FILES:=$(LINUX_DIR)/drivers/net/phy/rtl8366_smi.ko
AUTOLOAD:=$(call AutoLoad,42,rtl8366_smi,1)