aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2022-02-24 05:47:21 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2022-02-28 10:24:17 +0800
commit43276b60c6dd5adeec89401c6ddd514e2cd22896 (patch)
treea9678c32b645b55c64a7363d09b5ff21595c9c8f /package/kernel/linux
parent0225df1ec8570d144a0a8d7862036c532cc44dbd (diff)
downloadupstream-43276b60c6dd5adeec89401c6ddd514e2cd22896.tar.gz
upstream-43276b60c6dd5adeec89401c6ddd514e2cd22896.tar.bz2
upstream-43276b60c6dd5adeec89401c6ddd514e2cd22896.zip
netfilter: add kmod-nft-tproxy
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/netfilter.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 7200af769f..1707bf2d9f 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -1228,6 +1228,17 @@ endef
$(eval $(call KernelPackage,nft-socket))
+define KernelPackage/nft-tproxy
+ SUBMENU:=$(NF_MENU)
+ TITLE:=Netfilter nf_tables tproxy support
+ DEPENDS:=+kmod-nft-core +kmod-nf-tproxy +kmod-nf-conntrack
+ FILES:=$(foreach mod,$(NFT_TPROXY-m),$(LINUX_DIR)/net/$(mod).ko)
+ AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_TPROXY-m)))
+ KCONFIG:=$(KCONFIG_NFT_TPROXY)
+endef
+
+$(eval $(call KernelPackage,nft-tproxy))
+
define KernelPackage/nft-compat
SUBMENU:=$(NF_MENU)
TITLE:=Netfilter nf_tables compat support