aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorMatthew Hagan <mnhagan88@gmail.com>2021-05-13 19:29:45 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-11-28 17:41:18 +0100
commit529eac53719ab2b50a6e4585622c1119db5095b4 (patch)
treed22c766c7d407cfc1358de8db325b4e1b711108b /package/kernel/linux
parent3ad229db0b0ed8538eadcdc2a1c3faf964f239be (diff)
downloadupstream-529eac53719ab2b50a6e4585622c1119db5095b4.tar.gz
upstream-529eac53719ab2b50a6e4585622c1119db5095b4.tar.bz2
upstream-529eac53719ab2b50a6e4585622c1119db5095b4.zip
kernel: add back kmod-leds-tlc591xx
Add back support for the TLC591xx series LEDs which are used in the ipq806x-based Meraki Cryptid series devices. This module previously existed for the mvebu platform but was removed at commit f849c2c83247340d623fdb549e2b75f4c1feea62 due to being enabled in that platform's kernel config. Signed-off-by: Matthew Hagan <mnhagan88@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/leds.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/leds.mk b/package/kernel/linux/modules/leds.mk
index 8d104f5651..33b9f612ae 100644
--- a/package/kernel/linux/modules/leds.mk
+++ b/package/kernel/linux/modules/leds.mk
@@ -162,6 +162,24 @@ endef
$(eval $(call KernelPackage,leds-pwm))
+
+define KernelPackage/leds-tlc591xx
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=LED driver for TLC59108 and TLC59116 controllers
+ DEPENDS:=+kmod-i2c-core +kmod-regmap-i2c
+ KCONFIG:=CONFIG_LEDS_TLC591XX
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-tlc591xx.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-tlc591xx,1)
+endef
+
+define KernelPackage/leds-tlc591xx/description
+ This option enables support for Texas Instruments TLC59108
+ and TLC59116 LED controllers.
+endef
+
+$(eval $(call KernelPackage,leds-tlc591xx))
+
+
define KernelPackage/leds-uleds
SUBMENU:=$(LEDS_MENU)
TITLE:=Userspace LEDs