aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-01-15 19:38:33 +0100
committerChristian Lamparter <chunkeey@gmail.com>2022-01-15 19:55:14 +0100
commit0a08d4faad5d2b4e7b681e87799d1f6032b524f1 (patch)
treecd2df3a0a74e03ffc2031321abdcff3524adacae /package/kernel/linux
parent144609bb3dbed2d612031b7db62740688929161e (diff)
downloadupstream-0a08d4faad5d2b4e7b681e87799d1f6032b524f1.tar.gz
upstream-0a08d4faad5d2b4e7b681e87799d1f6032b524f1.tar.bz2
upstream-0a08d4faad5d2b4e7b681e87799d1f6032b524f1.zip
kernel: add missing kmod+regmap-i2c dependency for NCT7802Y module
x86, mt7623 and others buildbot failed due to: |Package kmod-hwmon-nct7802 is missing dependencies for the following libraries: |regmap-core.ko |regmap-i2c.ko Fixes: 1ed50b92d157 ("package: kernel: add driver module for NCT7802Y") Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/hwmon.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 01a510e571..943b87cd4c 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -353,7 +353,7 @@ define KernelPackage/hwmon-nct7802
KCONFIG:=CONFIG_SENSORS_NCT7802
FILES:=$(LINUX_DIR)/drivers/hwmon/nct7802.ko
AUTOLOAD:=$(call AutoProbe,nct7802)
- $(call AddDepends/hwmon,+kmod-i2c-core)
+ $(call AddDepends/hwmon,+kmod-regmap-i2c)
endef
define KernelPackage/hwmon-nct7802/description