aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-07-22 16:37:12 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2021-07-23 12:33:32 +0300
commit3cb22b277a312445bfe34f5e32626c4448f95b77 (patch)
treeef933300803c9827709961fd6c381bda985f1f57 /package/kernel/linux
parent6dc18649a013151f226c9a362e5060c703b6c642 (diff)
downloadupstream-3cb22b277a312445bfe34f5e32626c4448f95b77.tar.gz
upstream-3cb22b277a312445bfe34f5e32626c4448f95b77.tar.bz2
upstream-3cb22b277a312445bfe34f5e32626c4448f95b77.zip
kernel: add missing symbol to kmod-qlcnic
When the kmod-qlcnic package is built on targets that have CONFIG_PCI_IOV enabled, the CONFIG_QLCNIC_SRIOV symbol is exposed. Enable this symbol in the kmod package to fix its build. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/netdevices.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index b91442748d..6bbaf21e4a 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -1199,7 +1199,8 @@ define KernelPackage/qlcnic
TITLE:=QLogic QLE8240 and QLE8242 device support
KCONFIG:= \
CONFIG_QLCNIC \
- CONFIG_QLCNIC_HWMON=y
+ CONFIG_QLCNIC_HWMON=y \
+ CONFIG_QLCNIC_SRIOV=y
FILES:=$(LINUX_DIR)/drivers/net/ethernet/qlogic/qlcnic/qlcnic.ko
AUTOLOAD:=$(call AutoProbe,qlcnic)
endef