aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2018-01-14 16:15:30 +0200
committerJohn Crispin <john@phrozen.org>2018-02-13 11:49:26 +0100
commitde62386b2d11771d85b3849ca32a2e9ecf4e4194 (patch)
tree60da8cd81ee8317867fea15aa3aa990c6e211d1f /package/kernel/linux
parentc2d3047f25e4c0797b9840489506e66fa209da33 (diff)
downloadupstream-de62386b2d11771d85b3849ca32a2e9ecf4e4194.tar.gz
upstream-de62386b2d11771d85b3849ca32a2e9ecf4e4194.tar.bz2
upstream-de62386b2d11771d85b3849ca32a2e9ecf4e4194.zip
fs.mk: sort kernel modules
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/fs.mk146
1 files changed, 77 insertions, 69 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index f757585575..e04aac98f4 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -7,25 +7,6 @@
FS_MENU:=Filesystems
-define KernelPackage/fs-fscache
- SUBMENU:=$(FS_MENU)
- TITLE:=General filesystem local cache manager
- DEPENDS:=
- KCONFIG:=\
- CONFIG_FSCACHE=m \
- CONFIG_FSCACHE_STATS=y \
- CONFIG_FSCACHE_HISTOGRAM=n \
- CONFIG_FSCACHE_DEBUG=n \
- CONFIG_FSCACHE_OBJECT_LIST=n \
- CONFIG_CACHEFILES=y \
- CONFIG_CACHEFILES_DEBUG=n \
- CONFIG_CACHEFILES_HISTOGRAM=n
- FILES:=$(LINUX_DIR)/fs/fscache/fscache.ko
- AUTOLOAD:=$(call AutoLoad,29,fscache)
-endef
-
-$(eval $(call KernelPackage,fs-fscache))
-
define KernelPackage/fs-9p
SUBMENU:=$(FS_MENU)
TITLE:=Plan 9 Resource Sharing Support
@@ -45,6 +26,7 @@ endef
$(eval $(call KernelPackage,fs-9p))
+
define KernelPackage/fs-afs
SUBMENU:=$(FS_MENU)
TITLE:=Andrew FileSystem client
@@ -142,6 +124,7 @@ endef
$(eval $(call KernelPackage,fs-configfs))
+
define KernelPackage/fs-cramfs
SUBMENU:=$(FS_MENU)
TITLE:=Compressed RAM/ROM filesystem support
@@ -158,6 +141,7 @@ endef
$(eval $(call KernelPackage,fs-cramfs))
+
define KernelPackage/fs-exportfs
SUBMENU:=$(FS_MENU)
TITLE:=exportfs kernel server support
@@ -220,19 +204,24 @@ endef
$(eval $(call KernelPackage,fs-f2fs))
-define KernelPackage/fuse
+define KernelPackage/fs-fscache
SUBMENU:=$(FS_MENU)
- TITLE:=FUSE (Filesystem in Userspace) support
- KCONFIG:= CONFIG_FUSE_FS
- FILES:=$(LINUX_DIR)/fs/fuse/fuse.ko
- AUTOLOAD:=$(call AutoLoad,80,fuse)
-endef
-
-define KernelPackage/fuse/description
- Kernel module for userspace filesystem support
+ TITLE:=General filesystem local cache manager
+ DEPENDS:=
+ KCONFIG:=\
+ CONFIG_FSCACHE=m \
+ CONFIG_FSCACHE_STATS=y \
+ CONFIG_FSCACHE_HISTOGRAM=n \
+ CONFIG_FSCACHE_DEBUG=n \
+ CONFIG_FSCACHE_OBJECT_LIST=n \
+ CONFIG_CACHEFILES=y \
+ CONFIG_CACHEFILES_DEBUG=n \
+ CONFIG_CACHEFILES_HISTOGRAM=n
+ FILES:=$(LINUX_DIR)/fs/fscache/fscache.ko
+ AUTOLOAD:=$(call AutoLoad,29,fscache)
endef
-$(eval $(call KernelPackage,fuse))
+$(eval $(call KernelPackage,fs-fscache))
define KernelPackage/fs-hfs
@@ -284,6 +273,21 @@ endef
$(eval $(call KernelPackage,fs-isofs))
+define KernelPackage/fs-jfs
+ SUBMENU:=$(FS_MENU)
+ TITLE:=JFS filesystem support
+ KCONFIG:=CONFIG_JFS_FS
+ FILES:=$(LINUX_DIR)/fs/jfs/jfs.ko
+ AUTOLOAD:=$(call AutoLoad,30,jfs,1)
+ $(call AddDepends/nls)
+endef
+
+define KernelPackage/fs-jfs/description
+ Kernel module for JFS support
+endef
+
+$(eval $(call KernelPackage,fs-jfs))
+
define KernelPackage/fs-minix
SUBMENU:=$(FS_MENU)
TITLE:=Minix filesystem support
@@ -335,37 +339,6 @@ endef
$(eval $(call KernelPackage,fs-nfs))
-define KernelPackage/fs-nfs-v3
- SUBMENU:=$(FS_MENU)
- TITLE:=NFS3 filesystem client support
- DEPENDS:=+kmod-fs-nfs
- FILES:= \
- $(LINUX_DIR)/fs/nfs/nfsv3.ko
- AUTOLOAD:=$(call AutoLoad,41,nfsv3)
-endef
-
-define KernelPackage/fs-nfs-v3/description
- Kernel module for NFS v3 client support
-endef
-
-$(eval $(call KernelPackage,fs-nfs-v3))
-
-define KernelPackage/fs-nfs-v4
- SUBMENU:=$(FS_MENU)
- TITLE:=NFS4 filesystem client support
- DEPENDS:=+kmod-fs-nfs
- KCONFIG:= \
- CONFIG_NFS_V4=y
- FILES:= \
- $(LINUX_DIR)/fs/nfs/nfsv4.ko
- AUTOLOAD:=$(call AutoLoad,41,nfsv4)
-endef
-
-define KernelPackage/fs-nfs-v4/description
- Kernel module for NFS v4 support
-endef
-
-$(eval $(call KernelPackage,fs-nfs-v4))
define KernelPackage/fs-nfs-common
SUBMENU:=$(FS_MENU)
@@ -413,6 +386,40 @@ endef
$(eval $(call KernelPackage,fs-nfs-common-rpcsec))
+define KernelPackage/fs-nfs-v3
+ SUBMENU:=$(FS_MENU)
+ TITLE:=NFS3 filesystem client support
+ DEPENDS:=+kmod-fs-nfs
+ FILES:= \
+ $(LINUX_DIR)/fs/nfs/nfsv3.ko
+ AUTOLOAD:=$(call AutoLoad,41,nfsv3)
+endef
+
+define KernelPackage/fs-nfs-v3/description
+ Kernel module for NFS v3 client support
+endef
+
+$(eval $(call KernelPackage,fs-nfs-v3))
+
+
+define KernelPackage/fs-nfs-v4
+ SUBMENU:=$(FS_MENU)
+ TITLE:=NFS4 filesystem client support
+ DEPENDS:=+kmod-fs-nfs
+ KCONFIG:= \
+ CONFIG_NFS_V4=y
+ FILES:= \
+ $(LINUX_DIR)/fs/nfs/nfsv4.ko
+ AUTOLOAD:=$(call AutoLoad,41,nfsv4)
+endef
+
+define KernelPackage/fs-nfs-v4/description
+ Kernel module for NFS v4 support
+endef
+
+$(eval $(call KernelPackage,fs-nfs-v4))
+
+
define KernelPackage/fs-nfsd
SUBMENU:=$(FS_MENU)
TITLE:=NFS kernel server support
@@ -532,17 +539,18 @@ endef
$(eval $(call KernelPackage,fs-xfs))
-define KernelPackage/fs-jfs
+define KernelPackage/fuse
SUBMENU:=$(FS_MENU)
- TITLE:=JFS filesystem support
- KCONFIG:=CONFIG_JFS_FS
- FILES:=$(LINUX_DIR)/fs/jfs/jfs.ko
- AUTOLOAD:=$(call AutoLoad,30,jfs,1)
- $(call AddDepends/nls)
+ TITLE:=FUSE (Filesystem in Userspace) support
+ KCONFIG:= CONFIG_FUSE_FS
+ FILES:=$(LINUX_DIR)/fs/fuse/fuse.ko
+ AUTOLOAD:=$(call AutoLoad,80,fuse)
endef
-define KernelPackage/fs-jfs/description
- Kernel module for JFS support
+define KernelPackage/fuse/description
+ Kernel module for userspace filesystem support
endef
-$(eval $(call KernelPackage,fs-jfs))
+$(eval $(call KernelPackage,fuse))
+
+