aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-06-13 16:40:47 +0200
committerPetr Štetiar <ynezz@true.cz>2019-06-17 09:36:03 +0200
commit7046a249d8173212fe6bb7f5a4802d6e66ee15f2 (patch)
tree67b8bdb7fbe851bcc2f7fd4d9e9aca6f5fb90214 /package/kernel/linux
parent4d11c4c3784196ed3e5b5a1f81fa415d99ef32b0 (diff)
downloadupstream-7046a249d8173212fe6bb7f5a4802d6e66ee15f2.tar.gz
upstream-7046a249d8173212fe6bb7f5a4802d6e66ee15f2.tar.bz2
upstream-7046a249d8173212fe6bb7f5a4802d6e66ee15f2.zip
kernel: package module for SafeXcel crypto engine
Supports EIP97 and EIP197 found on Armada 37xx, 7k and 8k SoCs. Unfortunately firmware for EIP197 is not easily obtainable, therefore to not cause lot of user requests directed at OpenWrt, package it as module with explanation where to obtain the firmware. Cc: Marek Behún <marek.behun@nic.cz> Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/crypto.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 4e843e1a5e..17cb98302d 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -350,6 +350,31 @@ endef
$(eval $(call KernelPackage,crypto-hw-padlock))
+define KernelPackage/crypto-hw-safexcel
+ TITLE:= MVEBU SafeXcel Crypto Engine module
+ DEPENDS:=@!LINUX_4_14 @(TARGET_mvebu_cortexa53||TARGET_mvebu_cortexa72) \
+ +kmod-crypto-authenc +kmod-crypto-md5 +kmod-crypto-hmac +kmod-crypto-sha256 +kmod-crypto-sha512
+ KCONFIG:= \
+ CONFIG_CRYPTO_HW=y \
+ CONFIG_CRYPTO_DEV_SAFEXCEL
+ FILES:=$(LINUX_DIR)/drivers/crypto/inside-secure/crypto_safexcel.ko
+ AUTOLOAD:=$(call AutoLoad,90,crypto_safexcel)
+ $(call AddDepends/crypto)
+endef
+
+define KernelPackage/crypto-hw-safexcel/description
+MVEBU's EIP97 and EIP197 Cryptographic Engine driver designed by
+Inside Secure. This is found on Marvell Armada 37xx/7k/8k SoCs.
+
+Particular version of these IP (EIP197B and EIP197D) require firmware.
+Unfortunately it's not freely available and needs signed Non-Disclosure
+Agreement (NDA) with Marvell. For those who have signed NDA the firmware can be
+obtained at https://extranet.marvell.com.
+endef
+
+$(eval $(call KernelPackage,crypto-hw-safexcel))
+
+
define KernelPackage/crypto-hw-talitos
TITLE:=Freescale integrated security engine (SEC) driver
DEPENDS:=+kmod-crypto-manager +kmod-crypto-hash +kmod-random-core +kmod-crypto-authenc +kmod-crypto-des