aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-26 10:38:51 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-26 13:31:51 +0100
commitb24d91faf1551cfe993c1c755f75d947f4ff74b0 (patch)
tree47cc64b4006d961b1b19c44589e2aee874008277 /package/kernel/linux
parentd90abebd06bbb004fc7957c39fe89202fbdca9f2 (diff)
downloadupstream-b24d91faf1551cfe993c1c755f75d947f4ff74b0.tar.gz
upstream-b24d91faf1551cfe993c1c755f75d947f4ff74b0.tar.bz2
upstream-b24d91faf1551cfe993c1c755f75d947f4ff74b0.zip
kernel: enable hwmon-k10temp in the x86/64 kernel config instead of packaging it
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/hwmon.mk16
1 files changed, 0 insertions, 16 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 6223a37ab2..b39a2e2fe8 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -386,19 +386,3 @@ define KernelPackage/hwmon-pwmfan/description
endef
$(eval $(call KernelPackage,hwmon-pwmfan))
-
-
-define KernelPackage/hwmon-k10temp
- TITLE:=AMD Family 10h+ temperature sensor
- KCONFIG:=CONFIG_SENSORS_K10TEMP
- FILES:=$(LINUX_DIR)/drivers/hwmon/k10temp.ko
- AUTOLOAD:=$(call AutoLoad,60,k10temp)
- $(call AddDepends/hwmon,@PCI_SUPPORT @TARGET_x86)
-endef
-
-define KernelPackage/hwmon-k10temp/description
- Thermal sensor support for AMD 10h, 11h, 12h (Llano), 14h (Brazos),
- 15h (Bulldozer/Trinity/Kaveri) and 16h (Kabini/Mullins) CPUs
-endef
-
-$(eval $(call KernelPackage,hwmon-k10temp))