aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2019-01-02 13:30:37 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-01-05 22:09:07 +0100
commit0fbd3d23aadee0d95beef4f077a866dae7f4841a (patch)
tree3038cb713760d1f741b0fd3afea32663f73c2307 /package/kernel/linux
parent576c69938bb38c7edfa23f220eb30cb5c1d0a726 (diff)
downloadupstream-0fbd3d23aadee0d95beef4f077a866dae7f4841a.tar.gz
upstream-0fbd3d23aadee0d95beef4f077a866dae7f4841a.tar.bz2
upstream-0fbd3d23aadee0d95beef4f077a866dae7f4841a.zip
kernel: 4.19: kmod-ptp-gianfar follow upstream changes
This patch deprecates the kmod-ptp-gianfar package and introduces kmod-ptp-qoriq for 4.19+ in its place. This has become necessary due to the linux kernel commit ceefc71d4c05 ("ptp: rework gianfar_ptp as QorIQ common PTP driver") Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [reworded commit]
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/other.mk18
1 files changed, 17 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 89dbcd0d0a..cfb70553c3 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -852,7 +852,7 @@ $(eval $(call KernelPackage,ptp))
define KernelPackage/ptp-gianfar
SUBMENU:=$(OTHER_MENU)
TITLE:=Freescale Gianfar PTP support
- DEPENDS:=@TARGET_mpc85xx +kmod-ptp
+ DEPENDS:=@TARGET_mpc85xx +kmod-ptp @!LINUX_4_19
KCONFIG:=CONFIG_PTP_1588_CLOCK_GIANFAR
FILES:=$(LINUX_DIR)/drivers/net/ethernet/freescale/gianfar_ptp.ko
AUTOLOAD:=$(call AutoProbe,gianfar_ptp)
@@ -865,6 +865,22 @@ endef
$(eval $(call KernelPackage,ptp-gianfar))
+define KernelPackage/ptp-qoriq
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Freescale QorIQ PTP support
+ DEPENDS:=@TARGET_mpc85xx +kmod-ptp @LINUX_4_19
+ KCONFIG:=CONFIG_PTP_1588_CLOCK_QORIQ
+ FILES:=$(LINUX_DIR)/drivers/ptp/ptp_qoriq.o
+ AUTOLOAD:=$(call AutoProbe,ptp_qoriq)
+endef
+
+
+define KernelPackage/ptp-qoriq/description
+ Kernel module for IEEE 1588 support for Freescale
+ QorIQ Ethernet drivers
+endef
+
+$(eval $(call KernelPackage,ptp-qoriq))
define KernelPackage/random-core
SUBMENU:=$(OTHER_MENU)