aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2019-02-25 00:49:39 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2019-02-25 01:07:20 +0200
commit02cd7f8b7a44f1715706dc63d70b5ffbac36200a (patch)
treeaa2c85d9f3a6fdfaa19a1b40d1bcbe5230397416 /package/kernel/linux
parentb7f2adbdd3ed76e9c844b99d0171c9bfe5809cba (diff)
downloadupstream-02cd7f8b7a44f1715706dc63d70b5ffbac36200a.tar.gz
upstream-02cd7f8b7a44f1715706dc63d70b5ffbac36200a.tar.bz2
upstream-02cd7f8b7a44f1715706dc63d70b5ffbac36200a.zip
kernel: fix kmod-input-touchscreen-ads7846 deps
On targets that don't have input support enabled in the kernel config, building kmod-input-touchscreen-ads7846 fails due to a missing dependency on kmod-input-core. Add the dependency to fix this. Fixes: 77a54bbf13bf ("kernel: add kmod-input-touchscreen-ads7846") Reported-by: Hannu Nyman <hannu.nyman@iki.fi> Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/input.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 76b4f40bdd..99257b6725 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -176,7 +176,7 @@ $(eval $(call KernelPackage,input-matrixkmap))
define KernelPackage/input-touchscreen-ads7846
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=ADS7846/TSC2046/AD7873 and AD(S)7843 based touchscreens
- DEPENDS:=+kmod-hwmon-core +kmod-spi-bitbang
+ DEPENDS:=+kmod-hwmon-core +kmod-input-core +kmod-spi-bitbang
KCONFIG:= \
CONFIG_INPUT_TOUCHSCREEN=y \
CONFIG_TOUCHSCREEN_PROPERTIES=y \