aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-07-18 20:40:15 +0000
committerJonas Gorski <jogo@openwrt.org>2013-07-18 20:40:15 +0000
commit7565b0335df503177dd6a04b05aa9964caa99a1c (patch)
treebdce80cc438b9729e1aa692236364bbb6f6a3173 /package/kernel/linux
parenta061e11e2ec606fc4c5c22bab1c013823446197e (diff)
downloadupstream-7565b0335df503177dd6a04b05aa9964caa99a1c.tar.gz
upstream-7565b0335df503177dd6a04b05aa9964caa99a1c.tar.bz2
upstream-7565b0335df503177dd6a04b05aa9964caa99a1c.zip
kernel: kmod-gpio-mcp23s08 depends on i2c-core
But only if it is selected, so make it a conditionl dependency. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37420 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 9e97bb566f..f850581ba7 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -135,7 +135,7 @@ $(eval $(call KernelPackage,gpio-dev))
define KernelPackage/gpio-mcp23s08
SUBMENU:=$(OTHER_MENU)
TITLE:=Microchip MCP23xxx I/O expander
- DEPENDS:=@GPIO_SUPPORT
+ DEPENDS:=@GPIO_SUPPORT +PACKAGE_kmod-i2c-core:kmod-i2c-core
KCONFIG:=CONFIG_GPIO_MCP23S08
FILES:=$(LINUX_DIR)/drivers/gpio/gpio-mcp23s08.ko
AUTOLOAD:=$(call AutoLoad,40,gpio-mcp23s08)