aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorMehdi Ahmadi <aphorise@gmail.com>2022-08-26 23:56:45 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2022-09-10 15:36:16 +0200
commitd02e887d7ceb25008fa70c42174207dfeb65b5f0 (patch)
tree8d2caf1f39ed0b5fd8daed625fe92aaf0dc25eea /package/kernel/linux/modules
parent90c6e3aedf167b0ae1baf376e7800a631681e69a (diff)
downloadupstream-d02e887d7ceb25008fa70c42174207dfeb65b5f0.tar.gz
upstream-d02e887d7ceb25008fa70c42174207dfeb65b5f0.tar.bz2
upstream-d02e887d7ceb25008fa70c42174207dfeb65b5f0.zip
kernel: add Aquantia AQtion Atlantic 10Gbps Ethernet
Driver support for Aquantia AQtion Atlantic 10Gbps Ethernet NIC with the AQC107, AQC108 and others chipsets found on: - TP-Link: TX401 - Asus: XG-C100C, ROG Areion 10G NIC - & more ... Successfully tested using a build with 22.03.0-rc6 (x86_64/EFI image) and the following outputs: ``` [ 3.092053] pci 0000:06:00.0: [1d6a:07b1] type 00 class 0x020000 [ 3.094983] pci 0000:06:00.0: reg 0x10: [mem 0x50800000-0x5080ffff 64bit] [ 3.098880] pci 0000:06:00.0: reg 0x18: [mem 0x50810000-0x50810fff 64bit] [ 3.108868] pci 0000:06:00.0: reg 0x20: [mem 0x50400000-0x507fffff 64bit] [ 3.108883] pci 0000:06:00.0: enabling Extended Tags [ 3.118874] pci 0000:06:00.0: supports D1 D2 [ 3.118874] pci 0000:06:00.0: PME# supported from D0 D1 D2 D3hot D3cold [ 3.128891] pci 0000:06:00.0: 7.876 Gb/s available PCIe bandwidth, limited by 8.0 GT/s PCIe x1 link at 0000:00:1d.0 (capable of 31.504 Gb/s with 8.0 GT/s PCIe x4 link) [ 10.312793] atlantic 0000:06:00.0: enabling device (0000 -> 0002) [ 23.223813] atlantic 0000:06:00.0 eth0: atlantic: link change old 0 new 10000 lsmod && uname -ar ; # atlantic 147456 0 # # // ... # Linux version 5.10.138 (vagrant@make-host) (x86_64-openwrt-linux-musl-gcc (OpenWrt GCC 11.3.0 r20430-18a2b29aa1) 11.3.0, GNU ld (GNU Binutils) 2.37) #0 SMP Mon Aug 29 09:54:00 2022 ``` Signed-off-by: Mehdi Ahmadi <aphorise@gmail.com> Reviewed-by: Robert Marko <robimarko@gmail.com> [ fix wrong commit author as requested by author itself ] Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/netdevices.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 140459ab25..f048b01d8b 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -1457,3 +1457,19 @@ define KernelPackage/mhi-wwan-mbim/description
endef
$(eval $(call KernelPackage,mhi-wwan-mbim))
+
+define KernelPackage/atlantic
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Aquantia AQtion 10Gbps Ethernet NIC
+ DEPENDS:=@PCI_SUPPORT +kmod-ptp
+ KCONFIG:=CONFIG_AQTION
+ FILES:=$(LINUX_DIR)/drivers/net/ethernet/aquantia/atlantic/atlantic.ko
+ AUTOLOAD:=$(call AutoProbe,atlantic)
+endef
+
+define KernelPackage/atlantic/description
+ Kernel modules for Aquantia AQtion 10Gbps Ethernet NIC
+endef
+
+$(eval $(call KernelPackage,atlantic))
+