aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-09-14 20:23:17 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-09-14 20:26:58 +0100
commit8010d3da0376f68dd3724c30db0c4c9c513e5376 (patch)
treec24fb858054aeb4f9f3a80a5f656a1c54d84e526 /package/kernel/linux/modules
parentc4d030f24cff34737d7cf1f116022b8dbe45f5be (diff)
downloadupstream-8010d3da0376f68dd3724c30db0c4c9c513e5376.tar.gz
upstream-8010d3da0376f68dd3724c30db0c4c9c513e5376.tar.bz2
upstream-8010d3da0376f68dd3724c30db0c4c9c513e5376.zip
mediatek: build USB XHCI support as module
Instead of always including the XHCI driver in the kernel on all MediaTek boards, selectively include the kernel module only on boards which actually make use of USB functionality. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/usb.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index f3838b3981..4ee70d7eb9 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1746,6 +1746,7 @@ define KernelPackage/usb3
+TARGET_bcm53xx:kmod-usb-bcma \
+TARGET_bcm53xx:kmod-phy-bcm-ns-usb3 \
+TARGET_ramips_mt7621:kmod-usb-xhci-mtk \
+ +TARGET_mediatek:kmod-usb-xhci-mtk \
+TARGET_apm821xx_nand:kmod-usb-xhci-pci-renesas \
+TARGET_mvebu_cortexa9:kmod-usb-xhci-pci-renesas
KCONFIG:= \