aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-09-09 20:27:17 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-09-09 21:08:37 +0100
commit6d1a398c5be046fc4217f61b1215da6291b9fd0f (patch)
tree410ef9ab9eaf16e631896c2118778d0c004c2958 /package/kernel/linux/modules
parentf755c4103814cc99fd2c9701ba05aaff1884fc89 (diff)
downloadupstream-6d1a398c5be046fc4217f61b1215da6291b9fd0f.tar.gz
upstream-6d1a398c5be046fc4217f61b1215da6291b9fd0f.tar.bz2
upstream-6d1a398c5be046fc4217f61b1215da6291b9fd0f.zip
kernel: modules: bluetooth: include support for MediaTek USB
Enable MediaTek protocol in btusb module to support e.g. the Bluetooth part of the MT7921K NGFF/M.2 module. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 519bd2048f..0ab8c7ad4a 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -40,6 +40,8 @@ define KernelPackage/bluetooth
CONFIG_BT_BNEP \
CONFIG_BT_HCIBTUSB \
CONFIG_BT_HCIBTUSB_BCM=n \
+ CONFIG_BT_HCIBTUSB_MTK=y \
+ CONFIG_BT_HCIBTUSB_RTL=n \
CONFIG_BT_HCIUART \
CONFIG_BT_HCIUART_BCM=n \
CONFIG_BT_HCIUART_INTEL=n \