aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2016-12-17 21:37:51 +0100
committerJohn Crispin <john@phrozen.org>2016-12-20 09:35:36 +0100
commit87bc410f7c574e5142dd20044de4a914fc3bcaa2 (patch)
treee2268d03e7ca286040828ea4cb7921085981887b /package/kernel/linux/modules
parenta7cacc97357460a51d83abf589a80f6ab1a4d95a (diff)
downloadupstream-87bc410f7c574e5142dd20044de4a914fc3bcaa2.tar.gz
upstream-87bc410f7c574e5142dd20044de4a914fc3bcaa2.tar.bz2
upstream-87bc410f7c574e5142dd20044de4a914fc3bcaa2.zip
kernel: declare AddDepends in pcmcia.mk
Stack repeated definitions to easy further additions. Signen-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/pcmcia.mk20
1 files changed, 13 insertions, 7 deletions
diff --git a/package/kernel/linux/modules/pcmcia.mk b/package/kernel/linux/modules/pcmcia.mk
index 52c115be9d..eb01d0082f 100644
--- a/package/kernel/linux/modules/pcmcia.mk
+++ b/package/kernel/linux/modules/pcmcia.mk
@@ -28,13 +28,19 @@ endef
$(eval $(call KernelPackage,pcmcia-core))
-define KernelPackage/pcmcia-rsrc
+
+define AddDepends/pcmcia
SUBMENU:=$(PCMCIA_MENU)
+ DEPENDS+=kmod-pcmcia-core $(1)
+endef
+
+
+define KernelPackage/pcmcia-rsrc
TITLE:=PCMCIA resource support
- DEPENDS:=kmod-pcmcia-core
KCONFIG:=CONFIG_PCCARD_NONSTATIC=y
FILES:=$(LINUX_DIR)/drivers/pcmcia/pcmcia_rsrc.ko
AUTOLOAD:=$(call AutoLoad,26,pcmcia_rsrc)
+ $(call AddDepends/pcmcia)
endef
define KernelPackage/pcmcia-rsrc/description
@@ -45,26 +51,26 @@ $(eval $(call KernelPackage,pcmcia-rsrc))
define KernelPackage/pcmcia-yenta
- SUBMENU:=$(PCMCIA_MENU)
TITLE:=yenta socket driver
- DEPENDS:=kmod-pcmcia-rsrc
KCONFIG:=CONFIG_YENTA
FILES:=$(LINUX_DIR)/drivers/pcmcia/yenta_socket.ko
AUTOLOAD:=$(call AutoLoad,41,yenta_socket)
+ DEPENDS:=+kmod-pcmcia-rsrc
+ $(call AddDepends/pcmcia)
endef
$(eval $(call KernelPackage,pcmcia-yenta))
define KernelPackage/pcmcia-serial
- SUBMENU:=$(PCMCIA_MENU)
TITLE:=Serial devices support
- DEPENDS:=kmod-pcmcia-core +kmod-serial-8250
KCONFIG:= \
CONFIG_PCMCIA_SERIAL_CS \
CONFIG_SERIAL_8250_CS
- FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/serial_cs.ko
+ FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/serial_cs.ko
AUTOLOAD:=$(call AutoLoad,45,serial_cs)
+ DEPENDS:=+kmod-serial-8250
+ $(call AddDepends/pcmcia)
endef
define KernelPackage/pcmcia-serial/description