aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-10-23 13:24:42 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-10-24 12:11:02 +0000
commit49db2026e54e7d707834a49fdc87ce76629a168d (patch)
tree78bafa799d098bba9836192f0e7e54d282ae26da /package/kernel/linux/modules
parent69b9f0161e147d566b3b9572a0bc39a97c257fc0 (diff)
downloadupstream-49db2026e54e7d707834a49fdc87ce76629a168d.tar.gz
upstream-49db2026e54e7d707834a49fdc87ce76629a168d.tar.bz2
upstream-49db2026e54e7d707834a49fdc87ce76629a168d.zip
kernel: netfilter: reuse kconfig and files info from include dir
Less chance of missing out kconfig symbols at least Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/netfilter.mk32
1 files changed, 9 insertions, 23 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 53188eab5a..cc4c5ecb2a 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -245,7 +245,7 @@ $(eval $(call KernelPackage,ipt-filter))
define KernelPackage/ipt-offload
TITLE:=Netfilter routing/NAT offload support
- KCONFIG:=CONFIG_NETFILTER_XT_TARGET_FLOWOFFLOAD
+ KCONFIG:=$(KCONFIG_IPT_FLOW)
FILES:=$(foreach mod,$(IPT_FLOW-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir $(IPT_FLOW-m)))
$(call AddDepends/ipt,+kmod-nf-flow)
@@ -646,13 +646,8 @@ $(eval $(call KernelPackage,ipt-led))
define KernelPackage/ipt-tproxy
TITLE:=Transparent proxying support
DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-nf-conntrack6 +IPV6:kmod-ip6tables
- KCONFIG:= \
- CONFIG_NF_SOCKET_IPV4 \
- CONFIG_NF_SOCKET_IPV6 \
- CONFIG_NETFILTER_XT_MATCH_SOCKET \
- CONFIG_NETFILTER_XT_TARGET_TPROXY
- FILES:= \
- $(foreach mod,$(IPT_TPROXY-m),$(LINUX_DIR)/net/$(mod).ko)
+ KCONFIG:=$(KCONFIG_IPT_TPROXY)
+ FILES:=$(foreach mod,$(IPT_TPROXY-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir $(IPT_TPROXY-m)))
$(call AddDepends/ipt)
endef
@@ -666,11 +661,8 @@ $(eval $(call KernelPackage,ipt-tproxy))
define KernelPackage/ipt-tee
TITLE:=TEE support
DEPENDS:=+kmod-ipt-conntrack
- KCONFIG:= \
- CONFIG_NETFILTER_XT_TARGET_TEE
- FILES:= \
- $(LINUX_DIR)/net/netfilter/xt_TEE.ko \
- $(foreach mod,$(IPT_TEE-m),$(LINUX_DIR)/net/$(mod).ko)
+ KCONFIG:=$(KCONFIG_IPT_TEE)
+ FILES:=$(foreach mod,$(IPT_TEE-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir nf_tee $(IPT_TEE-m)))
$(call AddDepends/ipt)
endef
@@ -684,11 +676,8 @@ $(eval $(call KernelPackage,ipt-tee))
define KernelPackage/ipt-u32
TITLE:=U32 support
- KCONFIG:= \
- CONFIG_NETFILTER_XT_MATCH_U32
- FILES:= \
- $(LINUX_DIR)/net/netfilter/xt_u32.ko \
- $(foreach mod,$(IPT_U32-m),$(LINUX_DIR)/net/$(mod).ko)
+ KCONFIG:=$(KCONFIG_IPT_U32)
+ FILES:=$(foreach mod,$(IPT_U32-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir nf_tee $(IPT_U32-m)))
$(call AddDepends/ipt)
endef
@@ -701,11 +690,8 @@ $(eval $(call KernelPackage,ipt-u32))
define KernelPackage/ipt-checksum
TITLE:=CHECKSUM support
- KCONFIG:= \
- CONFIG_NETFILTER_XT_TARGET_CHECKSUM
- FILES:= \
- $(LINUX_DIR)/net/netfilter/xt_CHECKSUM.ko \
- $(foreach mod,$(IPT_CHECKSUM-m),$(LINUX_DIR)/net/$(mod).ko)
+ KCONFIG:=$(KCONFIG_IPT_CHECKSUM)
+ FILES:=$(foreach mod,$(IPT_CHECKSUM-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir $(IPT_CHECKSUM-m)))
$(call AddDepends/ipt)
endef