aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2020-02-18 17:47:20 -0300
committerHans Dedecker <dedeckeh@gmail.com>2020-02-19 22:07:40 +0100
commit07e1d88d7beb43a4152460b82976dbe49919b264 (patch)
tree3a92b0eb71751c1694f62f46c05ddddd5a1a0a89 /package/kernel/linux/modules
parent731f7ea48a8a1f62de1a63e52b2ed8e245f12ac3 (diff)
downloadupstream-07e1d88d7beb43a4152460b82976dbe49919b264.tar.gz
upstream-07e1d88d7beb43a4152460b82976dbe49919b264.tar.bz2
upstream-07e1d88d7beb43a4152460b82976dbe49919b264.zip
kernel: avoid underscore in *6lowpan package names
Packages kmod-bluetooth_6lowpan and kmod-ieee802154_6lowpan contain an underscore in the package name. This causes problems in package/install because when building a list of package files to install offline using opkg, it uses a wildcard of the form $(dir)/$(pkg)_*.ipk. If you were to select kmod-bluetooth=y, but kmod-bluetooth_6lowpan=m, the latter would be picked up by that wildcard, and make package/install would fail: Collected errors: * satisfy_dependencies_for: Cannot satisfy the following dependencies * for kmod-bluetooth_6lowpan: * kmod-6lowpan * opkg_install_cmd: Cannot install package kmod-bluetooth_6lowpan. Changing the wildcard pattern is not trivial, and there may be other places in the build system making this assumption about the package name format. Using a dash in place of the underscore avoids the issue. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/other.mk6
-rw-r--r--package/kernel/linux/modules/wpan.mk6
2 files changed, 6 insertions, 6 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 7549542308..16907a7336 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -84,7 +84,7 @@ endef
$(eval $(call KernelPackage,ath3k))
-define KernelPackage/bluetooth_6lowpan
+define KernelPackage/bluetooth-6lowpan
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth 6LoWPAN support
DEPENDS:=+kmod-6lowpan +kmod-bluetooth
@@ -93,11 +93,11 @@ define KernelPackage/bluetooth_6lowpan
AUTOLOAD:=$(call AutoProbe,bluetooth_6lowpan)
endef
-define KernelPackage/bluetooth_6lowpan/description
+define KernelPackage/bluetooth-6lowpan/description
Kernel support for 6LoWPAN over Bluetooth Low Energy devices
endef
-$(eval $(call KernelPackage,bluetooth_6lowpan))
+$(eval $(call KernelPackage,bluetooth-6lowpan))
define KernelPackage/btmrvl
diff --git a/package/kernel/linux/modules/wpan.mk b/package/kernel/linux/modules/wpan.mk
index b9e9fa5699..053fa1e4bf 100644
--- a/package/kernel/linux/modules/wpan.mk
+++ b/package/kernel/linux/modules/wpan.mk
@@ -116,7 +116,7 @@ endef
$(eval $(call KernelPackage,cc2520))
-define KernelPackage/ieee802154_6lowpan
+define KernelPackage/ieee802154-6lowpan
SUBMENU:=$(WPAN_MENU)
TITLE:= 6LoWPAN support over IEEE-802.15.4
DEPENDS:=+kmod-6lowpan +kmod-ieee802154
@@ -126,8 +126,8 @@ define KernelPackage/ieee802154_6lowpan
AUTOLOAD:=$(call AutoLoad,91,ieee802154_6lowpan)
endef
-define KernelPackage/ieee802154_6lowpan/description
+define KernelPackage/ieee802154-6lowpan/description
IPv6 compression over IEEE 802.15.4
endef
-$(eval $(call KernelPackage,ieee802154_6lowpan))
+$(eval $(call KernelPackage,ieee802154-6lowpan))