aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorRussell King <linux@armlinux.org.uk>2019-11-27 11:45:30 +0000
committerJonas Gorski <jonas.gorski@gmail.com>2020-01-21 22:32:48 +0100
commita1358fc7ae638b7dafe682ae764fc4d1d189b05e (patch)
tree14986f54963ffad73fd6393f6741f330c790718b /package/kernel/linux/modules
parent1c16b574c4f77a30a0268acee30be96ae0dc5948 (diff)
downloadupstream-a1358fc7ae638b7dafe682ae764fc4d1d189b05e.tar.gz
upstream-a1358fc7ae638b7dafe682ae764fc4d1d189b05e.tar.bz2
upstream-a1358fc7ae638b7dafe682ae764fc4d1d189b05e.zip
kernel: add SFP support for Methode DM7052 NBASE-T module
Add support for Methode DM7052 NBASE-T module to OpenWRT. These patches are taken from my "phy" branch, and will be sent for the next kernel merge window. Signed-off-by: Russell King <linux@armlinux.org.uk> [jonas.gorski: move patches to pending, refresh patches] Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/netdevices.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 610f7db82b..5bfd1617a3 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -192,6 +192,23 @@ endef
$(eval $(call KernelPackage,phy-broadcom))
+define KernelPackage/phy-bcm84881
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Broadcom BCM84881 PHY driver
+ KCONFIG:=CONFIG_BCM84881_PHY
+ DEPENDS:=+kmod-libphy
+ FILES:=$(LINUX_DIR)/drivers/net/phy/bcm84881.ko
+ AUTOLOAD:=$(call AutoLoad,18,bcm84881,1)
+endef
+
+define KernelPackage/phy-bcm84881/description
+ Supports the Broadcom 84881 PHY.
+endef
+
+$(eval $(call KernelPackage,phy-bcm84881))
+
+
+
define KernelPackage/phy-realtek
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Realtek Ethernet PHY driver