aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-07-18 22:34:58 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-07-18 22:34:58 +0000
commit6e094aeb9bed74c65034c00e6b5609fc48dd9129 (patch)
tree329383bb738c7afec0d4795ae67f182a527c7583 /package/kernel/linux/modules
parent0839afe00ffb9bcdc0986bf07d38d280d20c1269 (diff)
downloadupstream-6e094aeb9bed74c65034c00e6b5609fc48dd9129.tar.gz
upstream-6e094aeb9bed74c65034c00e6b5609fc48dd9129.tar.bz2
upstream-6e094aeb9bed74c65034c00e6b5609fc48dd9129.zip
kernel: fix OHCI and EHCI modules for AT91
We were not copying the additional files needed to get USB to work on the AT91 platforms, make sure we do this. Backport of r46172 Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46417 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/usb.mk13
1 files changed, 10 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 79186b29ec..d1ff455773 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -315,7 +315,10 @@ define KernelPackage/usb-ohci
FILES:= \
$(LINUX_DIR)/drivers/usb/host/ohci-hcd.ko \
$(LINUX_DIR)/drivers/usb/host/ohci-platform.ko
- AUTOLOAD:=$(call AutoLoad,50,ohci-hcd ohci-platform,1)
+ ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ohci-at91.ko),)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/ohci-at91.ko
+ endif
+ AUTOLOAD:=$(call AutoLoad,50,ohci-hcd ohci-platform ohci-at91,1)
$(call AddDepends/usb)
endef
@@ -416,14 +419,18 @@ define KernelPackage/usb2
CONFIG_USB_EHCI_MXC=y \
CONFIG_USB_OCTEON_EHCI=y \
CONFIG_USB_EHCI_HCD_ORION=y \
- CONFIG_USB_EHCI_HCD_PLATFORM=y
+ CONFIG_USB_EHCI_HCD_PLATFORM=y \
+ CONFIG_USB_EHCI_HCD_AT91=y
FILES:= \
$(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko \
$(LINUX_DIR)/drivers/usb/host/ehci-platform.ko
ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-orion.ko),)
FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-orion.ko
endif
- AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion,1)
+ ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko),)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko
+ endif
+ AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion ehci-atmel,1)
$(call AddDepends/usb)
endef