aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-06-16 05:04:53 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-06-16 05:04:53 +0000
commit1465aca8b662872b03c12fecfb4ab111469de9b0 (patch)
tree9775d2cbfbdfd3846e6a5557709e0c29867fc28f /package/kernel/linux/modules
parent72f50b76ff1bd82a89b606aa4148a89a9dbbac0f (diff)
downloadupstream-1465aca8b662872b03c12fecfb4ab111469de9b0.tar.gz
upstream-1465aca8b662872b03c12fecfb4ab111469de9b0.tar.bz2
upstream-1465aca8b662872b03c12fecfb4ab111469de9b0.zip
kernel: use bcma-hcd.ko on bcm53xx for ohci
On bcm53xx we still need usb-ohci to support USB 1.1 devices and it obviously needs bcma-hcd.ko that will init controller and register platform device. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> Backport of r45994 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@45996 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/usb.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 68f22cc05b..f27fcbd47f 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -300,6 +300,7 @@ $(eval $(call KernelPackage,usb-uhci,1))
define KernelPackage/usb-ohci
TITLE:=Support for OHCI controllers
DEPENDS:= \
+ +TARGET_bcm53xx:kmod-usb-bcma \
+TARGET_brcm47xx:kmod-usb-bcma \
+TARGET_brcm47xx:kmod-usb-ssb
KCONFIG:= \