aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/video.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-02-19 23:03:15 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-02-20 00:02:50 +0100
commit7878215a56b7943aa87a3016035d63f84950df8e (patch)
tree14acf9d72ff0bfa328aba078a9d9ae323209a12f /package/kernel/linux/modules/video.mk
parent02644e56126d2dafcc2eb1391e03b4fcf22a9a7d (diff)
downloadupstream-7878215a56b7943aa87a3016035d63f84950df8e.tar.gz
upstream-7878215a56b7943aa87a3016035d63f84950df8e.tar.bz2
upstream-7878215a56b7943aa87a3016035d63f84950df8e.zip
x86: Make kmod-drm-radeon and kmod-drm-amdgpu depend on x86
Currently these kernel packages only work on x86, restrict them to that target. Fixes: 2f239c02a031 ("x86: video: add amdgpu DRM kernel package") Fixes: 2f6918ee9be9 ("x86: video: add radeon DRM module support") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel/linux/modules/video.mk')
-rw-r--r--package/kernel/linux/modules/video.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index 92d027a30c..ed0e1d3c3d 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -181,7 +181,7 @@ $(eval $(call KernelPackage,drm))
define KernelPackage/drm-amdgpu
SUBMENU:=$(VIDEO_MENU)
TITLE:=AMDGPU DRM support
- DEPENDS:=@DISPLAY_SUPPORT +kmod-drm +kmod-i2c-algo-bit +amdgpu-firmware
+ DEPENDS:=@TARGET_x86 @DISPLAY_SUPPORT +kmod-drm +kmod-i2c-algo-bit +amdgpu-firmware
KCONFIG:=CONFIG_DRM_AMDGPU \
CONFIG_DRM_AMDGPU_SI=y \
CONFIG_DRM_AMDGPU_CIK=y \
@@ -287,7 +287,7 @@ $(eval $(call KernelPackage,drm-imx-ldb))
define KernelPackage/drm-radeon
SUBMENU:=$(VIDEO_MENU)
TITLE:=Radeon DRM support
- DEPENDS:=@DISPLAY_SUPPORT +kmod-drm +kmod-i2c-algo-bit +radeon-firmware
+ DEPENDS:=@TARGET_x86 @DISPLAY_SUPPORT +kmod-drm +kmod-i2c-algo-bit +radeon-firmware
KCONFIG:=CONFIG_DRM_RADEON
FILES:=$(LINUX_DIR)/drivers/gpu/drm/radeon/radeon.ko
AUTOLOAD:=$(call AutoProbe,radeon)