aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/video.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-01-03 21:31:41 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-02-01 17:35:34 +0100
commit3b401215308e042253f61a00e7e2047169c38863 (patch)
tree85a7fb3cc5714db8395976d8dd9466eb05066e96 /package/kernel/linux/modules/video.mk
parent3da230a2e618187d94d69e53a057d56b7d5f9de7 (diff)
downloadupstream-3b401215308e042253f61a00e7e2047169c38863.tar.gz
upstream-3b401215308e042253f61a00e7e2047169c38863.tar.bz2
upstream-3b401215308e042253f61a00e7e2047169c38863.zip
kernel: Fix drm dependency on drm_panel_orientation_quirks.ko for 4.19
Package kmod-drm is missing dependencies for the following libraries: drm_panel_orientation_quirks.ko It seems, that since Linux 4.15-rc2 drm depends on drm_panel_orientation_quirks.ko commit 8d70f395e6cbece665b12b4bf6dbc48d12623014 Author: Hans de Goede <j.w.r.degoede@gmail.com> Date: Sat Nov 25 20:35:49 2017 +0100 drm: Add support for a panel-orientation connector property, v6 On some devices the LCD panel is mounted in the casing in such a way that the up/top side of the panel does not match with the top side of the device (e.g. it is mounted upside-down). This commit adds the necessary infra for lcd-panel drm_connector-s to have a "panel orientation" property to communicate how the panel is orientated vs the casing. Userspace can use this property to check for non-normal orientation and then adjust the displayed image accordingly by rotating it to compensate. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package/kernel/linux/modules/video.mk')
-rw-r--r--package/kernel/linux/modules/video.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index 7e300bf486..17436cdc31 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -166,7 +166,9 @@ define KernelPackage/drm
HIDDEN:=1
DEPENDS:=+kmod-dma-buf +kmod-i2c-core
KCONFIG:=CONFIG_DRM
- FILES:=$(LINUX_DIR)/drivers/gpu/drm/drm.ko
+ FILES:= \
+ $(LINUX_DIR)/drivers/gpu/drm/drm.ko \
+ $(LINUX_DIR)/drivers/gpu/drm/drm_panel_orientation_quirks.ko@ge4.15
AUTOLOAD:=$(call AutoLoad,05,drm)
endef