aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/video.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:39 +0000
commit91521083342d845c2807854992229fb61918dced (patch)
tree909af996b354eb5676f888ee9d6608b118179a42 /package/kernel/linux/modules/video.mk
parent81a0c585eb24c24546b2dfae21641cd133dc8b21 (diff)
downloadupstream-91521083342d845c2807854992229fb61918dced.tar.gz
upstream-91521083342d845c2807854992229fb61918dced.tar.bz2
upstream-91521083342d845c2807854992229fb61918dced.zip
kernel: remove useless AddDepends/input abstraction
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45135 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/video.mk')
-rw-r--r--package/kernel/linux/modules/video.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index 25ef9cb7dc..7a7d80c534 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -184,12 +184,11 @@ $(eval $(call KernelPackage,video-pwc))
define KernelPackage/video-uvc
TITLE:=USB Video Class (UVC) support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2 +kmod-input-core
KCONFIG:= CONFIG_USB_VIDEO_CLASS
FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/uvc/uvcvideo.ko
AUTOLOAD:=$(call AutoProbe,uvcvideo)
$(call AddDepends/camera)
- $(call AddDepends/input)
endef
define KernelPackage/video-uvc/description