aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorLeo Soares <leo@hyper.ag>2022-07-31 15:21:42 +0100
committerChristian Lamparter <chunkeey@gmail.com>2022-08-05 14:10:42 +0200
commit2b03f207e038ec2ba8f57f55cc93e211af2e1a75 (patch)
tree631880d26e499edfe47300560891bee2480ae3c4 /package/kernel/linux/modules/usb.mk
parent3678881773c6257f0db8d343aaa903f54fd695f5 (diff)
downloadupstream-2b03f207e038ec2ba8f57f55cc93e211af2e1a75.tar.gz
upstream-2b03f207e038ec2ba8f57f55cc93e211af2e1a75.tar.bz2
upstream-2b03f207e038ec2ba8f57f55cc93e211af2e1a75.zip
kernel: add kmod-usb-hid-mcp2221
"The MCP2221 is a USB-to-UART/I2C serial converter which enables USB connectivity in applications that have a UART and I2C interfaces." <https://www.microchip.com/en-us/product/MCP2221> Signed-off-by: Leo Soares <leo@hyper.ag> (replaced GPIOLIB KConfig with @GPIO_SUPPORT) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 8f0eac7522..84097ac34a 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1555,6 +1555,23 @@ endef
$(eval $(call KernelPackage,usb-hid-cp2112))
+define KernelPackage/usb-hid-mcp2221
+ SUBMENU:=$(USB_MENU)
+ TITLE:=Microchip USB 2.0 to I2C/UART Protocol Converter with GPIO
+ KCONFIG:=CONFIG_HID_MCP2221
+ DEPENDS:=@GPIO_SUPPORT +kmod-usb-hid +kmod-i2c-core
+ FILES:=$(LINUX_DIR)/drivers/hid/hid-mcp2221.ko
+ AUTOLOAD:=$(call AutoProbe,hid-mcp2221)
+endef
+
+define KernelPackage/usb-hid-mcp2221/description
+ HID device driver which registers as an i2c adapter and gpiochip to expose
+ these functions of the MCP2221.
+endef
+
+$(eval $(call KernelPackage,usb-hid-mcp2221))
+
+
define KernelPackage/usb-yealink
TITLE:=USB Yealink VOIP phone
DEPENDS:=+kmod-input-evdev