aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-06-17 20:54:41 +0300
committerJohn Crispin <john@phrozen.org>2018-06-18 20:29:38 +0200
commit163ab9135a9148d510cd19ca90782835e8ca80bb (patch)
tree5478dd900935254d6a5349a6a25eb8ef3bd4e2f5 /package/kernel/linux/modules/usb.mk
parentdcfe2a461e4b06de6e2b23d29afebbb3c775f647 (diff)
downloadupstream-163ab9135a9148d510cd19ca90782835e8ca80bb.tar.gz
upstream-163ab9135a9148d510cd19ca90782835e8ca80bb.tar.bz2
upstream-163ab9135a9148d510cd19ca90782835e8ca80bb.zip
kernel/modules: add chaoskey module, hardware TRNG
Package the driver for Chaoskey, a USB dongle that provides a True Random Number Generator (TRNG) and feeds entropy to kernel. Chaoskey driver is included the upstream Linux sources, so only packaging it is needed. Run-tested with ipq806x/R7800 and mvebu/WRT3200ACM. (Requires CONFIG_HW_RANDOM kernel option.) Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 5e10f9eab5..2cf48e468f 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1639,3 +1639,18 @@ endef
$(eval $(call KernelPackage,usb-net2280))
+define KernelPackage/chaoskey
+ SUBMENU:=$(USB_MENU)
+ TITLE:=Chaoskey hardware RNG support
+ KCONFIG:=CONFIG_USB_CHAOSKEY
+ FILES:=$(LINUX_DIR)/drivers/usb/misc/chaoskey.ko
+ AUTOLOAD:=$(call AutoProbe,chaoskey)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/chaoskey/description
+ Kernel module for chaoskey, USB attached true random number generator
+endef
+
+$(eval $(call KernelPackage,chaoskey))
+