aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorMarty Jones <mj8263788@gmail.com>2021-07-10 04:00:30 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2022-01-08 00:49:59 +0100
commit3fe253c6abc2ccc02ea789cffc47761b2381c6ca (patch)
tree8a93f05f745e99ad00d10e1d9156cd029a88c99f /package/kernel/linux/modules/usb.mk
parent9d878d84227ffac92b5616fb9a4253cae28fc580 (diff)
downloadupstream-3fe253c6abc2ccc02ea789cffc47761b2381c6ca.tar.gz
upstream-3fe253c6abc2ccc02ea789cffc47761b2381c6ca.tar.bz2
upstream-3fe253c6abc2ccc02ea789cffc47761b2381c6ca.zip
linux-firmware: add new package r8152-firmware
Linux upstream commit https://github.com/torvalds/linux/commit/9370f2d05a2a150b0aa719a3070b26d478180df3 add load firmware file through request_firmware,this affect the nanopi r2s and some USB adapters in kernel 5.10 with this error: 'r8152 4-1:1.0: unable to load firmware patch rtl_nic/rtl8153b-2.fw' This patch split the USB NIC firmware files from r8169 firmware, and adds r8152-firmware to r8152 driver. Add kmod-usb-net-cdc-ncm to support RTL8156A and RTL8156B 2.5G ethernet adapters supported since v5.13-rc1. https://github.com/torvalds/linux/commit/195aae321c829dd1945900d75561e6aa79cce208 Signed-off-by: Marty Jones <mj8263788@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index ce7c57bf73..8815b153ef 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1356,6 +1356,7 @@ $(eval $(call KernelPackage,usb-net-rtl8150))
define KernelPackage/usb-net-rtl8152
TITLE:=Kernel module for USB-to-Ethernet Realtek convertors
+ DEPENDS:=+r8152-firmware +kmod-crypto-sha256 +kmod-usb-net-cdc-ncm
KCONFIG:=CONFIG_USB_RTL8152
FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/r8152.ko
AUTOLOAD:=$(call AutoProbe,r8152)