aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2020-08-10 13:56:15 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-13 02:12:12 +0200
commit0c45ad41e15e2255ca5fc6c8d4ce9164aaa1d26e (patch)
tree80136a9f25a48f8b594854efc963d6be90b959c5 /package/kernel/linux/modules/usb.mk
parente5eeb34a8cde8c91e86dc2bdee98d693db4822cf (diff)
downloadupstream-0c45ad41e15e2255ca5fc6c8d4ce9164aaa1d26e.tar.gz
upstream-0c45ad41e15e2255ca5fc6c8d4ce9164aaa1d26e.tar.bz2
upstream-0c45ad41e15e2255ca5fc6c8d4ce9164aaa1d26e.zip
ipq806x: replace phy dwc3 patch with upstream version
- Replace dwc3 phy patch with upstream version - Rework the dts to use the upstream bindings - Update changed config flags - Rename module to reflect config name Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com> [fix qcom,tx-deamp_3_5db typo, refresh patches, rename kmod] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Tested-by: Paul Blazejowski <paulb@blazebox.homeip.net> [R7800]
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk14
1 files changed, 7 insertions, 7 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index e4f6a226fd..5db0244968 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -70,22 +70,22 @@ endef
$(eval $(call KernelPackage,usb-phy-nop))
-define KernelPackage/usb-phy-qcom-dwc3
- TITLE:=DWC3 USB QCOM PHY driver
+define KernelPackage/phy-qcom-ipq806x-usb
+ TITLE:=Qualcomm IPQ806x DWC3 USB PHY driver
DEPENDS:=@(TARGET_ipq40xx||TARGET_ipq806x)
- KCONFIG:= CONFIG_PHY_QCOM_DWC3
+ KCONFIG:= CONFIG_PHY_QCOM_IPQ806X_USB
FILES:= \
- $(LINUX_DIR)/drivers/phy/qualcomm/phy-qcom-dwc3.ko
- AUTOLOAD:=$(call AutoLoad,45,phy-qcom-dwc3,1)
+ $(LINUX_DIR)/drivers/phy/qualcomm/phy-qcom-ipq806x-usb.ko
+ AUTOLOAD:=$(call AutoLoad,45,phy-qcom-ipq806x-usb,1)
$(call AddDepends/usb)
endef
-define KernelPackage/usb-phy-qcom-dwc3/description
+define KernelPackage/phy-qcom-ipq806x-usb/description
This driver provides support for the integrated DesignWare
USB3 IP Core within the QCOM SoCs.
endef
-$(eval $(call KernelPackage,usb-phy-qcom-dwc3))
+$(eval $(call KernelPackage,phy-qcom-ipq806x-usb))
define KernelPackage/phy-ath79-usb