aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorLinus Walleij <linus.walleij@linaro.org>2018-10-18 11:30:27 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-10-20 16:13:39 +0200
commit10ec966f7ba7471a8af437c317cdcc5ef8865e8d (patch)
tree8716efe946e4f868d7c861287383d0d364c01f2b /package/kernel/linux/modules/usb.mk
parentb2c68ceea76a41a484d24a12d20c6988dd59e83f (diff)
downloadupstream-10ec966f7ba7471a8af437c317cdcc5ef8865e8d.tar.gz
upstream-10ec966f7ba7471a8af437c317cdcc5ef8865e8d.tar.bz2
upstream-10ec966f7ba7471a8af437c317cdcc5ef8865e8d.zip
gemini: Break out USB to packages
This creates a new kernel package for the fotg210 host controller and uses that with the gemini to shrink the kernel. The SQ201 needs the USB2 PCI package as well. The build system required me to make kernel_oldconfig beofore it would build without errors so some minor unrelated Kconfig entries are changed. Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 8a4915712b..61a876b4d9 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -318,6 +318,17 @@ define KernelPackage/usb-bcma
endef
$(eval $(call KernelPackage,usb-bcma))
+define KernelPackage/usb-fotg210
+ TITLE:=Support for FOTG210 USB host controllers
+ DEPENDS:=@USB_SUPPORT @TARGET_gemini
+ KCONFIG:=CONFIG_USB_FOTG210_HCD
+ FILES:= \
+ $(if $(CONFIG_USB_FOTG210_HCD),$(LINUX_DIR)/drivers/usb/host/fotg210-hcd.ko)
+ AUTOLOAD:=$(call AutoLoad,50,fotg210-hcd,1)
+ $(call AddDepends/usb)
+endef
+$(eval $(call KernelPackage,usb-fotg210))
+
define KernelPackage/usb-ssb
TITLE:=Support for SSB USB controllers
DEPENDS:=@USB_SUPPORT @TARGET_brcm47xx