aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2019-04-14 22:34:52 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-04-15 00:20:56 +0200
commitd599890efd6c4d83ea83f285862c25e8be6c1a89 (patch)
tree78bdea672453152e1deafa3136b805ab38e1c09b /package/kernel/linux/modules/usb.mk
parent324e94f31bfdcf9c2245303434b087b306de0262 (diff)
downloadupstream-d599890efd6c4d83ea83f285862c25e8be6c1a89.tar.gz
upstream-d599890efd6c4d83ea83f285862c25e8be6c1a89.tar.bz2
upstream-d599890efd6c4d83ea83f285862c25e8be6c1a89.zip
layerscape: unbreak ehci-fsl interaction with mpc85xx
Both targets have their own idea of how to use ehci-fsl. This patch reverts part of commit 68b8d3b0796d ("kernel: usb: add FSL EHCI package") and moves ehci-fsl back into kmod-usb2, while also making it hopefully useable for the mpc85xx target. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk31
1 files changed, 9 insertions, 22 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index f11758c662..e2fe06f977 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -385,7 +385,8 @@ define KernelPackage/usb2
CONFIG_USB_EHCI_MXC=y \
CONFIG_USB_OCTEON_EHCI=y \
CONFIG_USB_EHCI_HCD_ORION=y \
- CONFIG_USB_EHCI_HCD_AT91=y
+ CONFIG_USB_EHCI_HCD_AT91=y \
+ CONFIG_USB_EHCI_FSL
FILES:= \
$(LINUX_DIR)/drivers/usb/host/ehci-platform.ko
ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-orion.ko),)
@@ -394,7 +395,13 @@ define KernelPackage/usb2
ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko),)
FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko
endif
- AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion ehci-atmel,1)
+ ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko),)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko
+ endif
+ ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko),)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko
+ endif
+ AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion ehci-atmel ehci-fsl fsl-mph-dr-of,1)
$(call AddDepends/usb)
endef
@@ -405,26 +412,6 @@ endef
$(eval $(call KernelPackage,usb2))
-define KernelPackage/usb2-fsl
- TITLE:=Support for Freescale USB2 controllers
- DEPENDS:=+kmod-usb-ehci @TARGET_mpc85xx
- KCONFIG:= \
- CONFIG_USB_EHCI_HCD_PPC_OF=y \
- CONFIG_USB_EHCI_FSL=y
- FILES:= \
- $(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko \
- $(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko
- AUTOLOAD:=$(call AutoLoad,42,ehci-fsl fsl-mph-dr-of,1)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb2-fsl/description
- Kernel support for Freescale USB2 (EHCI) controllers
-endef
-
-$(eval $(call KernelPackage,usb2-fsl))
-
-
define KernelPackage/usb2-pci
TITLE:=Support for PCI USB2 controllers
DEPENDS:=@PCI_SUPPORT +kmod-usb2