aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/spi.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-10 13:26:33 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-10 13:44:26 +0100
commit96815fe0a2c1a7395d0e5aceba4a58e85ec32b41 (patch)
tree1d07941ee2fd9f905578dd7d31e3d32636ffb2dc /package/kernel/linux/modules/spi.mk
parent7ff7be96dd3491a4762a33c5b5062e5680a99849 (diff)
downloadupstream-96815fe0a2c1a7395d0e5aceba4a58e85ec32b41.tar.gz
upstream-96815fe0a2c1a7395d0e5aceba4a58e85ec32b41.tar.bz2
upstream-96815fe0a2c1a7395d0e5aceba4a58e85ec32b41.zip
kernel: remove omap24xx specific kernel module packages
If the target is ever restored, those drivers should be built into the kernel instead. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/spi.mk')
-rw-r--r--package/kernel/linux/modules/spi.mk17
1 files changed, 0 insertions, 17 deletions
diff --git a/package/kernel/linux/modules/spi.mk b/package/kernel/linux/modules/spi.mk
index 0b535a8cb4..1c2a789fed 100644
--- a/package/kernel/linux/modules/spi.mk
+++ b/package/kernel/linux/modules/spi.mk
@@ -89,20 +89,3 @@ define KernelPackage/spi-dev/description
endef
$(eval $(call KernelPackage,spi-dev))
-
-define KernelPackage/spi-omap-24xx
- SUBMENU:=$(SPI_MENU)
- TITLE:=SPI omap 24xx
- DEPENDS:=@TARGET_omap24xx
- KCONFIG:=CONFIG_SPI_OMAP24XX \
- CONFIG_SPI=y \
- CONFIG_SPI_MASTER=y
- FILES:=$(LINUX_DIR)/drivers/spi/spi-omap2-mcspi.ko
- AUTOLOAD:=$(call AutoProbe,spi-omap2-mcspi)
-endef
-
-define KernelPackage/spi-dev/description
- This package contains the user mode SPI device driver
-endef
-
-$(eval $(call KernelPackage,spi-omap-24xx))