aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-09-30 11:42:06 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2022-12-27 08:05:23 +0100
commit6be9e3e63685a11577f6650b51f45c72ef82180c (patch)
tree098c4a40a9ad80b72fa7c3879169d99c02c425c0 /package/kernel/linux/modules/other.mk
parentb1722a048ae920a24dfb898b7c97ebb6e1593e37 (diff)
downloadupstream-6be9e3e63685a11577f6650b51f45c72ef82180c.tar.gz
upstream-6be9e3e63685a11577f6650b51f45c72ef82180c.tar.bz2
upstream-6be9e3e63685a11577f6650b51f45c72ef82180c.zip
kernel: remove hack patch, move kirkwood specific kmods to target modules.mk
Tweaking the KCONFIG line of kmod-ata-marvell-sata makes the hack patch unnecessary Signed-off-by: Felix Fietkau <nbd@nbd.name> (cherry picked from commit 2e375e9b3148cfdb9b19494a25eebc2fa7b256a3)
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk17
1 files changed, 0 insertions, 17 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 48b240a365..36f4c8a57e 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -391,23 +391,6 @@ endef
$(eval $(call KernelPackage,mmc))
-define KernelPackage/mvsdio
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Marvell MMC/SD/SDIO host driver
- DEPENDS:=+kmod-mmc @TARGET_kirkwood
- KCONFIG:= CONFIG_MMC_MVSDIO
- FILES:= \
- $(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
- AUTOLOAD:=$(call AutoProbe,mvsdio,1)
-endef
-
-define KernelPackage/mvsdio/description
- Kernel support for the Marvell SDIO host driver.
-endef
-
-$(eval $(call KernelPackage,mvsdio))
-
-
define KernelPackage/sdhci
SUBMENU:=$(OTHER_MENU)
TITLE:=Secure Digital Host Controller Interface support