aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-10 13:26:33 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-10 13:44:26 +0100
commit96815fe0a2c1a7395d0e5aceba4a58e85ec32b41 (patch)
tree1d07941ee2fd9f905578dd7d31e3d32636ffb2dc /package/kernel/linux/modules/other.mk
parent7ff7be96dd3491a4762a33c5b5062e5680a99849 (diff)
downloadupstream-96815fe0a2c1a7395d0e5aceba4a58e85ec32b41.tar.gz
upstream-96815fe0a2c1a7395d0e5aceba4a58e85ec32b41.tar.bz2
upstream-96815fe0a2c1a7395d0e5aceba4a58e85ec32b41.zip
kernel: remove omap24xx specific kernel module packages
If the target is ever restored, those drivers should be built into the kernel instead. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk32
1 files changed, 0 insertions, 32 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index adf3cc4069..017a94c622 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -114,22 +114,6 @@ endef
$(eval $(call KernelPackage,bluetooth_6lowpan))
-define KernelPackage/bluetooth-hci-h4p
- SUBMENU:=$(OTHER_MENU)
- TITLE:=HCI driver with H4 Nokia extensions
- DEPENDS:=@TARGET_omap24xx +kmod-bluetooth
- KCONFIG:=CONFIG_BT_HCIH4P
- FILES:=$(LINUX_DIR)/drivers/bluetooth/hci_h4p/hci_h4p.ko
- AUTOLOAD:=$(call AutoProbe,hci_h4p)
-endef
-
-define KernelPackage/bluetooth-hci-h4p/description
- HCI driver with H4 Nokia extensions
-endef
-
-$(eval $(call KernelPackage,bluetooth-hci-h4p))
-
-
define KernelPackage/dma-buf
SUBMENU:=$(OTHER_MENU)
TITLE:=DMA shared buffer support
@@ -482,22 +466,6 @@ endef
$(eval $(call KernelPackage,bcma))
-define KernelPackage/wdt-omap
- SUBMENU:=$(OTHER_MENU)
- TITLE:=OMAP Watchdog timer
- DEPENDS:=@TARGET_omap24xx
- KCONFIG:=CONFIG_OMAP_WATCHDOG
- FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/omap_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,omap_wdt,1)
-endef
-
-define KernelPackage/wdt-omap/description
- Kernel module for TI omap watchdog timer
-endef
-
-$(eval $(call KernelPackage,wdt-omap))
-
-
define KernelPackage/rtc-ds1307
SUBMENU:=$(OTHER_MENU)
TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support