aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-07-30 22:33:51 +0200
committerJohn Crispin <john@phrozen.org>2018-07-30 22:37:22 +0200
commitd00913d1215b4877da67431b3dadf51fe5d0c443 (patch)
tree0e0c777d48c8ad40dacf5502db60e1821c52fc76 /package/kernel/linux/modules/other.mk
parent50c5fdd54d5f189df0979f1255ec50b88c90a702 (diff)
downloadupstream-d00913d1215b4877da67431b3dadf51fe5d0c443.tar.gz
upstream-d00913d1215b4877da67431b3dadf51fe5d0c443.tar.bz2
upstream-d00913d1215b4877da67431b3dadf51fe5d0c443.zip
kernel: modules: fix kmod-regmap
This patch fixes the a compile issue that was triggered by apm821xx/sata when kmod-regmap was selected. The CONFIG_REGMAP is declared in drivers/base/regmap/Kconfig as type "bool" and not "tristate". Hence the symbol should never be set to module, as this confuses the #if CONFIG_REGMAP guards in include/linux/regmap.h: |.../drivers/regulator/core.c:4041: undefined reference to `dev_get_regmap' |.../drivers/regulator/core.c:4042: undefined reference to `dev_get_regmap' |.../drivers/regulator/core.c:4044: undefined reference to `dev_get_regmap' |.../drivers/regulator/helpers.o: In function `regulator_is_enabled_regmap': |.../drivers/regulator/helpers.c:36: undefined reference to `regmap_read' |... Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 7e18a21db3..dd037cf86c 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -718,7 +718,7 @@ define KernelPackage/regmap
SUBMENU:=$(OTHER_MENU)
TITLE:=Generic register map support
DEPENDS:=+kmod-lib-lzo +kmod-i2c-core
- KCONFIG:=CONFIG_REGMAP \
+ KCONFIG:=CONFIG_REGMAP=y \
CONFIG_REGMAP_MMIO \
CONFIG_REGMAP_SPI \
CONFIG_REGMAP_I2C \