aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2019-06-20 21:46:55 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-06-22 13:17:47 +0200
commitc4fb2213762295c848349c83c322af2adda86834 (patch)
tree9d09403d379723b67cc1a616f7df1257d295fce5 /package/kernel/linux/modules/other.mk
parent6762e72524075c37928ad4ae9a979257759b2703 (diff)
downloadupstream-c4fb2213762295c848349c83c322af2adda86834.tar.gz
upstream-c4fb2213762295c848349c83c322af2adda86834.tar.bz2
upstream-c4fb2213762295c848349c83c322af2adda86834.zip
kernel: fix kmod-tpm 4.19 dependencies
This patch fixes the ath79-nand build error: |Package kmod-tpm is missing dependencies for the following libraries: |rng-core.ko by making it depend on rng-core from 4.19 onwards. This should work as 4.9 is gone so only 4.14 and 4.19 are there. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 16b438461e..e98b8a9223 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1085,6 +1085,7 @@ $(eval $(call KernelPackage,bmp085-spi))
define KernelPackage/tpm
SUBMENU:=$(OTHER_MENU)
TITLE:=TPM Hardware Support
+ DEPENDS:= +!LINUX_4_14:kmod-random-core
KCONFIG:= CONFIG_TCG_TPM
FILES:= $(LINUX_DIR)/drivers/char/tpm/tpm.ko
AUTOLOAD:=$(call AutoLoad,10,tpm,1)