aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorJianhui Zhao <jianhuizhao329@gmail.com>2017-10-30 13:32:31 +0800
committerJohn Crispin <john@phrozen.org>2017-11-15 21:13:16 +0100
commita8a23ca50caec2477e180bdf1f8d040f7824a23b (patch)
tree389e3a84c513953786a1edfff08355dbf39e12e2 /package/kernel/linux/modules/other.mk
parent0d5e024e09c08b65c3cd5724c7cefdaa46fd9237 (diff)
downloadupstream-a8a23ca50caec2477e180bdf1f8d040f7824a23b.tar.gz
upstream-a8a23ca50caec2477e180bdf1f8d040f7824a23b.tar.bz2
upstream-a8a23ca50caec2477e180bdf1f8d040f7824a23b.zip
kernel: add packaging for mtdoops
Signed-off-by: Jianhui Zhao <jianhuizhao329@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index a08134c256..1d07a16420 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -604,6 +604,20 @@ endef
$(eval $(call KernelPackage,mtdtests))
+define KernelPackage/mtdoops
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Log panic/oops to an MTD buffer
+ KCONFIG:=CONFIG_MTD_OOPS
+ FILES:=$(LINUX_DIR)/drivers/mtd/mtdoops.ko
+endef
+
+define KernelPackage/mtdoops/description
+ Kernel modules for Log panic/oops to an MTD buffer
+endef
+
+$(eval $(call KernelPackage,mtdoops))
+
+
define KernelPackage/serial-8250
SUBMENU:=$(OTHER_MENU)
TITLE:=8250 UARTs