aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-21 11:55:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-21 11:55:30 +0000
commit94439c2b5d797a1e18ae9ff81a76a8e53ce2fa09 (patch)
treeac52617d4248bc1c6267b252073f30decac690ae /package/kernel/linux/modules/other.mk
parent8fc44d1f5f472d980f7209757bfc674d5b9da5a2 (diff)
downloadupstream-94439c2b5d797a1e18ae9ff81a76a8e53ce2fa09.tar.gz
upstream-94439c2b5d797a1e18ae9ff81a76a8e53ce2fa09.tar.bz2
upstream-94439c2b5d797a1e18ae9ff81a76a8e53ce2fa09.zip
kernel: add a new global config symbol for enabling rfkill support (can be enabled by default via target feature flag)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37491
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 44bc870b88..b9ffaa0e42 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -239,6 +239,7 @@ $(eval $(call KernelPackage,oprofile))
define KernelPackage/rfkill
SUBMENU:=$(OTHER_MENU)
TITLE:=RF switch subsystem support
+ DEPENDS:=@USE_RFKILL +kmod-input-core
KCONFIG:= \
CONFIG_RFKILL \
CONFIG_RFKILL_INPUT=y \
@@ -247,7 +248,6 @@ define KernelPackage/rfkill
FILES:= \
$(LINUX_DIR)/net/rfkill/rfkill.ko
AUTOLOAD:=$(call AutoLoad,20,rfkill)
- $(call SetDepends/rfkill,+kmod-input-core)
endef
define KernelPackage/rfkill/description