aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-01-03 13:13:10 +0100
committerJo-Philipp Wich <jo@mein.io>2018-01-07 12:33:47 +0100
commit34e9937f2afdf512506836e27cbc4a720049453f (patch)
tree4385518cf920094a02efdc91ebc6d27433a41e5a /package/kernel/linux/modules/other.mk
parent3f5e39e960921167421317e2cdf6a37ae1330352 (diff)
downloadupstream-34e9937f2afdf512506836e27cbc4a720049453f.tar.gz
upstream-34e9937f2afdf512506836e27cbc4a720049453f.tar.bz2
upstream-34e9937f2afdf512506836e27cbc4a720049453f.zip
kernel: fix packaging of kmod-gpio-nxp-74hc164
The NXP 74HC164 GPIO expander driver uses a different config symbol ("CONFIG_GPIO_74X164") and module name since since at least Kernel version 2.6.37. Update the kmod package definition accordingly by adjusting kconfig and module file names. This unrelated, but correct change has been separated from the WNR2000v5 support commits. Ref: https://github.com/lede-project/source/pull/1256 Suggested-by: Raphael Catolino <raphael.catolino@gmail.com> Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 1c7869e7c6..973e4f3e26 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -242,9 +242,9 @@ $(eval $(call KernelPackage,gpio-mcp23s08))
define KernelPackage/gpio-nxp-74hc164
SUBMENU:=$(OTHER_MENU)
TITLE:=NXP 74HC164 GPIO expander support
- KCONFIG:=CONFIG_GPIO_NXP_74HC164
- FILES:=$(LINUX_DIR)/drivers/gpio/nxp_74hc164.ko
- AUTOLOAD:=$(call AutoProbe,nxp_74hc164)
+ KCONFIG:=CONFIG_GPIO_74X164
+ FILES:=$(LINUX_DIR)/drivers/gpio/gpio-74x164.ko
+ AUTOLOAD:=$(call AutoProbe,gpio-74x164)
endef
define KernelPackage/gpio-nxp-74hc164/description