aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-10 13:12:31 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-10 13:44:26 +0100
commit7ff7be96dd3491a4762a33c5b5062e5680a99849 (patch)
tree971de94729c3ad6afe483729b88cc9225451c7ec /package/kernel/linux/modules/other.mk
parent10f7a8d6482e4f8b7704a1a6f313bf30aa8d510e (diff)
downloadupstream-7ff7be96dd3491a4762a33c5b5062e5680a99849.tar.gz
upstream-7ff7be96dd3491a4762a33c5b5062e5680a99849.tar.bz2
upstream-7ff7be96dd3491a4762a33c5b5062e5680a99849.zip
omap: build various core drivers into the kernel instead of packaging them
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 81c04705de..adf3cc4069 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -485,7 +485,7 @@ $(eval $(call KernelPackage,bcma))
define KernelPackage/wdt-omap
SUBMENU:=$(OTHER_MENU)
TITLE:=OMAP Watchdog timer
- DEPENDS:=@(TARGET_omap24xx||TARGET_omap35xx)
+ DEPENDS:=@TARGET_omap24xx
KCONFIG:=CONFIG_OMAP_WATCHDOG
FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/omap_wdt.ko
AUTOLOAD:=$(call AutoLoad,50,omap_wdt,1)
@@ -849,7 +849,7 @@ define KernelPackage/random-omap
TITLE:=Hardware Random Number Generator OMAP support
KCONFIG:=CONFIG_HW_RANDOM_OMAP
FILES:=$(LINUX_DIR)/drivers/char/hw_random/omap-rng.ko
- DEPENDS:=@(TARGET_omap24xx||TARGET_omap) +kmod-random-core
+ DEPENDS:=@TARGET_omap24xx +kmod-random-core
AUTOLOAD:=$(call AutoProbe,random-omap)
endef