aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2017-02-26 04:04:51 -0600
committerJohn Crispin <john@phrozen.org>2017-02-27 11:39:23 +0100
commit3fcc4b656aeafc30221927806e9a3f641b9377f3 (patch)
tree26d78236e312de58619517bb26bc3b59fe46a440 /package/kernel/linux/modules/other.mk
parenteb09d79c163c9f9f913c57eed90d866e458d5ea7 (diff)
downloadupstream-3fcc4b656aeafc30221927806e9a3f641b9377f3.tar.gz
upstream-3fcc4b656aeafc30221927806e9a3f641b9377f3.tar.bz2
upstream-3fcc4b656aeafc30221927806e9a3f641b9377f3.zip
kernel: Add TPM Module support
The following will enable the TPM kernel module, as well as support for the atmel i2c TPM driver. Tested and confirmed working on an Aerohive AP-121 Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index b39a88be4d..3b2d2e9667 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -954,3 +954,50 @@ define KernelPackage/bmp085-spi/description
endef
$(eval $(call KernelPackage,bmp085-spi))
+
+define KernelPackage/tpm
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=TPM Hardware Support
+ KCONFIG:= CONFIG_TCG_TPM
+ FILES:= $(LINUX_DIR)/drivers/char/tpm/tpm.ko
+ AUTOLOAD:=$(call AutoLoad,10,tpm,1)
+endef
+
+define KernelPackage/tpm/description
+ This enables TPM Hardware Support.
+endef
+
+$(eval $(call KernelPackage,tpm))
+
+define KernelPackage/tpm-tis
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=TPM TIS 1.2 Interface / TPM 2.0 FIFO Interface
+ DEPENDS:= @TARGET_x86 +kmod-tpm
+ KCONFIG:= CONFIG_TCG_TIS
+ FILES:= $(LINUX_DIR)/drivers/char/tpm/tpm_tis.ko
+ AUTOLOAD:=$(call AutoLoad,20,tpm_tis,1)
+endef
+
+define KernelPackage/tpm-tis/description
+ If you have a TPM security chip that is compliant with the
+ TCG TIS 1.2 TPM specification (TPM1.2) or the TCG PTP FIFO
+ specification (TPM2.0) say Yes and it will be accessible from
+ within Linux.
+endef
+
+$(eval $(call KernelPackage,tpm-tis))
+
+define KernelPackage/tpm-i2c-atmel
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=TPM I2C Atmel Support
+ DEPENDS:= +kmod-tpm +kmod-i2c-core
+ KCONFIG:= CONFIG_TCG_TIS_I2C_ATMEL
+ FILES:= $(LINUX_DIR)/drivers/char/tpm/tpm_i2c_atmel.ko
+ AUTOLOAD:=$(call AutoLoad,40,tpm_i2c_atmel,1)
+endef
+
+define KernelPackage/tpm-i2c-atmel/description
+ This enables the TPM Interface Specification 1.2 Interface (I2C - Atmel)
+endef
+
+$(eval $(call KernelPackage,tpm-i2c-atmel))