aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-22 11:40:17 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-27 11:18:27 +0100
commit28af0f2fbd4fb66ecebdbbeca385054a2b105d3d (patch)
tree79098f361ad94ec69a33b6b842ac8bb4e38745be /package/kernel/linux/modules/other.mk
parent0519bafbdaef7b2b6d3b553fa487e625f87fd176 (diff)
downloadupstream-28af0f2fbd4fb66ecebdbbeca385054a2b105d3d.tar.gz
upstream-28af0f2fbd4fb66ecebdbbeca385054a2b105d3d.tar.bz2
upstream-28af0f2fbd4fb66ecebdbbeca385054a2b105d3d.zip
kernel: make kmod package dependencies forward compatible
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 017a94c622..370dc29671 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -30,7 +30,7 @@ $(eval $(call KernelPackage,6lowpan))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid +!LINUX_3_18:kmod-crypto-cmac +LINUX_4_4:kmod-regmap
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid +!LINUX_3_18:kmod-crypto-cmac +!LINUX_3_18:kmod-regmap
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \