aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-11-12 22:06:38 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-12-16 22:13:04 +0100
commit199273324ee705edc35b49a02fc1a28e635610ab (patch)
tree9bffea794f472384a2ac32e7f79822e1f6f4e6b2 /package/kernel/linux/modules/other.mk
parentf1e839dd33243973c8bd044e03066967a4b7405d (diff)
downloadupstream-199273324ee705edc35b49a02fc1a28e635610ab.tar.gz
upstream-199273324ee705edc35b49a02fc1a28e635610ab.tar.bz2
upstream-199273324ee705edc35b49a02fc1a28e635610ab.zip
kernel: add kmod-crypto-ecdh
In kernel 4.14 kmod-bluetooth depends on kmod-crypto-ecdh, add kmod-crypto-ecdh to LEDE. Both packages also depend on the kmod-crypto-kpp package. To build this we have to fix the dependency of CRYPTO_ECDH which has a typo. This patch is already accepted upstream. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 8e2f3a012d..b3ad4a051e 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -30,7 +30,7 @@ $(eval $(call KernelPackage,6lowpan))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid +!LINUX_3_18:kmod-crypto-cmac +!LINUX_3_18:kmod-regmap
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid +!LINUX_3_18:kmod-crypto-cmac +!LINUX_3_18:kmod-regmap +LINUX_4_14:kmod-crypto-ecdh
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \