aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2018-12-12 22:00:44 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2018-12-12 22:15:11 +0200
commitbcb859235328c9de0a2e0966785f5ca61419290c (patch)
tree7c4350238130eb4ae4a51a4b15e014180470a740 /package/kernel/linux/modules/other.mk
parent3198ec5b9d91d001aad8c9ea462827b9ce953a5e (diff)
downloadupstream-bcb859235328c9de0a2e0966785f5ca61419290c.tar.gz
upstream-bcb859235328c9de0a2e0966785f5ca61419290c.tar.bz2
upstream-bcb859235328c9de0a2e0966785f5ca61419290c.zip
kmod-dma-buf: fix build with external kernel
In hack/904-debloat_dma_buf.patch, DMA_SHARED_BUFFER is changed from bool to tristate. As this patch is not applied to external kernel sources, build fails if kmod-dma-buf is enabled. Fix this by only including the module file if CONFIG_EXTERNAL_KERNEL_TREE and CONFIG_KERNEL_GIT_CLONE_URI are not enabled. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 3269459397..958e818da1 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -129,7 +129,11 @@ define KernelPackage/dma-buf
TITLE:=DMA shared buffer support
HIDDEN:=1
KCONFIG:=CONFIG_DMA_SHARED_BUFFER
- FILES:=$(LINUX_DIR)/drivers/dma-buf/dma-shared-buffer.ko
+ ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
+ ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
+ FILES:=$(LINUX_DIR)/drivers/dma-buf/dma-shared-buffer.ko
+ endif
+ endif
AUTOLOAD:=$(call AutoLoad,20,dma-shared-buffer)
endef
$(eval $(call KernelPackage,dma-buf))