aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-04-13 13:06:34 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-04-13 13:06:34 +0000
commit8c684f42e574be8a6bac73eaa26cac86edbc18eb (patch)
treee6c52bcbb6726e37044ca9380683ae5723321738 /package/kernel/linux/modules/other.mk
parentc9e6c7c8364572eac35206627aac4b9d2e551d62 (diff)
downloadupstream-8c684f42e574be8a6bac73eaa26cac86edbc18eb.tar.gz
upstream-8c684f42e574be8a6bac73eaa26cac86edbc18eb.tar.bz2
upstream-8c684f42e574be8a6bac73eaa26cac86edbc18eb.zip
mvebu: add support for the in-CPU RTC on the Armada 38x
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 45415
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index bfdda2c389..a93583bf74 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -573,6 +573,23 @@ endef
$(eval $(call KernelPackage,rtc-marvell))
+
+define KernelPackage/rtc-armada38x
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Marvell Armada 38x SoC built-in RTC support
+ DEPENDS:=@RTC_SUPPORT @TARGET_mvebu
+ KCONFIG:=CONFIG_RTC_DRV_ARMADA38X
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-armada38x.ko
+ AUTOLOAD:=$(call AutoProbe,rtc-armada38x)
+endef
+
+define KernelPackage/rtc-armada38x/description
+ Kernel module for Marvell Armada 38x SoC built-in RTC.
+endef
+
+$(eval $(call KernelPackage,rtc-armada38x))
+
+
define KernelPackage/rtc-pcf8563
SUBMENU:=$(OTHER_MENU)
TITLE:=Philips PCF8563/Epson RTC8564 RTC support