aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2019-08-24 14:02:31 +0200
committerFelix Fietkau <nbd@nbd.name>2019-08-26 18:21:13 +0200
commitc3a78955f34a61d402044f357f54f21c75a19ff9 (patch)
treecef612184685e92313a8263feab83712d40326e7 /package/kernel/linux/modules/netsupport.mk
parent0e22e14b6c11a1adf0316f891c9abc6a7b407c5e (diff)
downloadupstream-c3a78955f34a61d402044f357f54f21c75a19ff9.tar.gz
upstream-c3a78955f34a61d402044f357f54f21c75a19ff9.tar.bz2
upstream-c3a78955f34a61d402044f357f54f21c75a19ff9.zip
kernel: move crypto-arc4 into a module
It is no longer required by wireless drivers, so we can save some space here Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index b0d1da33d1..7d8a57d11a 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -733,7 +733,7 @@ $(eval $(call KernelPackage,ipoa))
define KernelPackage/mppe
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Microsoft PPP compression/encryption
- DEPENDS:=kmod-ppp +kmod-crypto-sha1 +kmod-crypto-ecb
+ DEPENDS:=kmod-ppp +kmod-crypto-arc4 +kmod-crypto-sha1 +kmod-crypto-ecb
KCONFIG:= \
CONFIG_PPP_MPPE_MPPC \
CONFIG_PPP_MPPE