aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netfilter.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2022-04-12 13:38:23 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-04-19 23:57:14 +0200
commit204259356e7d421b359d3a7c67ec662a5eaecf76 (patch)
treeabc91d7d8bf22ee85eeb7b4b21781bf6ca3752b6 /package/kernel/linux/modules/netfilter.mk
parent688a59bd9433c0a64f15f04029ede5a4acac206c (diff)
downloadupstream-204259356e7d421b359d3a7c67ec662a5eaecf76.tar.gz
upstream-204259356e7d421b359d3a7c67ec662a5eaecf76.tar.bz2
upstream-204259356e7d421b359d3a7c67ec662a5eaecf76.zip
netfilter: move nf-log modules into separate packages
Both legacy iptables and nftables require nf-log modules for rule logging, so move them into a separate package both firewall implementations can depend on. Signed-off-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit bea01fa57f5c9c333138bbbc5c9f83b9d7553fb5)
Diffstat (limited to 'package/kernel/linux/modules/netfilter.mk')
-rw-r--r--package/kernel/linux/modules/netfilter.mk29
1 files changed, 26 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 1707bf2d9f..1ebe40947a 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -57,7 +57,7 @@ define KernelPackage/nf-ipt6
KCONFIG:=$(KCONFIG_NF_IPT6)
FILES:=$(foreach mod,$(NF_IPT6-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir $(NF_IPT6-m)))
- DEPENDS:=+kmod-nf-ipt
+ DEPENDS:=+kmod-nf-ipt +kmod-nf-log6
endef
$(eval $(call KernelPackage,nf-ipt6))
@@ -70,7 +70,7 @@ define KernelPackage/ipt-core
KCONFIG:=$(KCONFIG_IPT_CORE)
FILES:=$(foreach mod,$(IPT_CORE-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir $(IPT_CORE-m)))
- DEPENDS:=+kmod-nf-reject +kmod-nf-ipt
+ DEPENDS:=+kmod-nf-reject +kmod-nf-ipt +kmod-nf-log
endef
define KernelPackage/ipt-core/description
@@ -121,6 +121,29 @@ endef
$(eval $(call KernelPackage,nf-conntrack6))
+define KernelPackage/nf-log
+ SUBMENU:=$(NF_MENU)
+ TITLE:=Netfilter Logging
+ KCONFIG:=$(KCONFIG_NF_LOG)
+ FILES:=$(foreach mod,$(NF_LOG-m),$(LINUX_DIR)/net/$(mod).ko)
+ AUTOLOAD:=$(call AutoProbe,$(notdir $(NF_LOG-m)))
+endef
+
+$(eval $(call KernelPackage,nf-log))
+
+
+define KernelPackage/nf-log6
+ SUBMENU:=$(NF_MENU)
+ TITLE:=Netfilter IPV6 Logging
+ KCONFIG:=$(KCONFIG_NF_LOG6)
+ DEPENDS:=@IPV6 +kmod-nf-log
+ FILES:=$(foreach mod,$(NF_LOG6-m),$(LINUX_DIR)/net/$(mod).ko)
+ AUTOLOAD:=$(call AutoProbe,$(notdir $(NF_LOG6-m)))
+endef
+
+$(eval $(call KernelPackage,nf-log6))
+
+
define KernelPackage/nf-nat
SUBMENU:=$(NF_MENU)
TITLE:=Netfilter NAT
@@ -1089,7 +1112,7 @@ $(eval $(call KernelPackage,ipt-rpfilter))
define KernelPackage/nft-core
SUBMENU:=$(NF_MENU)
TITLE:=Netfilter nf_tables support
- DEPENDS:=+kmod-nfnetlink +kmod-nf-reject +IPV6:kmod-nf-reject6 +IPV6:kmod-nf-conntrack6 +kmod-nf-nat +kmod-lib-crc32c
+ DEPENDS:=+kmod-nfnetlink +kmod-nf-reject +IPV6:kmod-nf-reject6 +IPV6:kmod-nf-conntrack6 +kmod-nf-nat +kmod-nf-log +IPV6:kmod-nf-log6 +kmod-lib-crc32c
FILES:=$(foreach mod,$(NFT_CORE-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_CORE-m)))
KCONFIG:= \