aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netfilter.mk
diff options
context:
space:
mode:
authorKristian Evensen <kristian.evensen@gmail.com>2018-01-22 18:52:28 +0100
committerJohn Crispin <john@phrozen.org>2018-02-13 10:01:52 +0100
commit2d27ebbb9338c114b3b5403cd4eb6fc05ef1ed6a (patch)
treed221a0c6ef81d236547b5b67a5b127112e1daa6c /package/kernel/linux/modules/netfilter.mk
parentf226e652f6e8bdca5ce552ef1e0e8ec98bf8ce9a (diff)
downloadupstream-2d27ebbb9338c114b3b5403cd4eb6fc05ef1ed6a.tar.gz
upstream-2d27ebbb9338c114b3b5403cd4eb6fc05ef1ed6a.tar.bz2
upstream-2d27ebbb9338c114b3b5403cd4eb6fc05ef1ed6a.zip
iptables: Support building connlabel module
It is currently possible to enable connlabel-support in iptables. However, in order for connlabel to work properly, the kernel module must also be present. This patch adds support for building the connlabel-module, and selects it by default when connlabel-support is enabled. Signed-off-by: Kristian Evensen <kristian.evensen@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/netfilter.mk')
-rw-r--r--package/kernel/linux/modules/netfilter.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index d44d2f8f3b..82d5604841 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -187,6 +187,21 @@ endef
$(eval $(call KernelPackage,ipt-conntrack-extra))
+define KernelPackage/ipt-conntrack-label
+ TITLE:=Module for handling connection tracking labels
+ KCONFIG:=$(KCONFIG_IPT_CONNTRACK_LABEL)
+ FILES:=$(foreach mod,$(IPT_CONNTRACK_LABEL-m),$(LINUX_DIR)/net/$(mod).ko)
+ AUTOLOAD:=$(call AutoProbe,$(notdir $(IPT_CONNTRACK_LABEL-m)))
+ $(call AddDepends/ipt,+kmod-ipt-conntrack)
+endef
+
+define KernelPackage/ipt-conntrack-label/description
+ Netfilter (IPv4) module for handling connection tracking labels
+ Includes:
+ - connlabel
+endef
+
+$(eval $(call KernelPackage,ipt-conntrack-label))
define KernelPackage/ipt-filter
TITLE:=Modules for packet content inspection