aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netfilter.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-09-30 23:28:21 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-09-30 23:32:05 +0200
commitcea09329e50f5766b6b44149aa17e4a681546bbb (patch)
treed0357252ebccba5b9cfdb93bce00e4469d8b63d0 /package/kernel/linux/modules/netfilter.mk
parentc50ba61cafa616becf43e6a0148abea42935e03b (diff)
downloadupstream-cea09329e50f5766b6b44149aa17e4a681546bbb.tar.gz
upstream-cea09329e50f5766b6b44149aa17e4a681546bbb.tar.bz2
upstream-cea09329e50f5766b6b44149aa17e4a681546bbb.zip
netfilter: fix file conflicts between kmod-ipt- and kmod-nft- packages
The nf_reject_* and nf_nat_masquerade_* modules are moved into the corresponding kmod-nf- packages. Appropriate dependencies are added to the kmod-nft- packages. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'package/kernel/linux/modules/netfilter.mk')
-rw-r--r--package/kernel/linux/modules/netfilter.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index ccbd20a643..f72d0c9736 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -819,7 +819,7 @@ $(eval $(call KernelPackage,ipt-hashlimit))
define KernelPackage/nft-core
SUBMENU:=$(NF_MENU)
TITLE:=Netfilter nf_tables support
- DEPENDS:=+kmod-nfnetlink +kmod-nf-conntrack6
+ DEPENDS:=+kmod-nfnetlink +kmod-nf-conntrack6 +kmod-nf-ipt +kmod-nf-ipt6
FILES:=$(foreach mod,$(NFT_CORE-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_CORE-m)))
KCONFIG:= \
@@ -842,7 +842,7 @@ $(eval $(call KernelPackage,nft-core))
define KernelPackage/nft-nat
SUBMENU:=$(NF_MENU)
TITLE:=Netfilter nf_tables NAT support
- DEPENDS:=+kmod-nft-core +kmod-nf-nat
+ DEPENDS:=+kmod-nft-core +kmod-nf-nat +kmod-nf-nat6
FILES:=$(foreach mod,$(NFT_NAT-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_NAT-m)))
KCONFIG:=$(KCONFIG_NFT_NAT)