aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netfilter.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-13 14:54:55 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-14 12:13:14 +0100
commit970dd4dd58c1f1c1b4cde69a732483aacdc0236a (patch)
tree635b7e2d4530a77bf50e3ff722f95ce5a132d595 /package/kernel/linux/modules/netfilter.mk
parent565988ab47bd9b96b50608564aee2104aeb4b7ae (diff)
downloadupstream-970dd4dd58c1f1c1b4cde69a732483aacdc0236a.tar.gz
upstream-970dd4dd58c1f1c1b4cde69a732483aacdc0236a.tar.bz2
upstream-970dd4dd58c1f1c1b4cde69a732483aacdc0236a.zip
kernel: netfilter: split out iptable_raw into a separate package
This will avoid loading it in the default configuration, which reduces image size a bit, and (more importantly) improves performance by avoiding some unnecessary netfilter hooks Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/netfilter.mk')
-rw-r--r--package/kernel/linux/modules/netfilter.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index c21f58d79b..bc2f349c76 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -289,6 +289,28 @@ endef
$(eval $(call KernelPackage,ipt-nat))
+define KernelPackage/ipt-raw
+ TITLE:=Netfilter IPv4 raw table support
+ KCONFIG:=CONFIG_IP_NF_RAW
+ FILES:=$(LINUX_DIR)/net/ipv4/netfilter/iptable_raw.ko
+ AUTOLOAD:=$(call AutoProbe,iptable_raw)
+ $(call AddDepends/ipt)
+endef
+
+$(eval $(call KernelPackage,ipt-raw))
+
+
+define KernelPackage/ipt-raw6
+ TITLE:=Netfilter IPv6 raw table support
+ KCONFIG:=CONFIG_IP6_NF_RAW
+ FILES:=$(LINUX_DIR)/net/ipv6/netfilter/ip6table_raw.ko
+ AUTOLOAD:=$(call AutoProbe,ip6table_raw)
+ $(call AddDepends/ipt,+kmod-ip6tables)
+endef
+
+$(eval $(call KernelPackage,ipt-raw6))
+
+
define KernelPackage/ipt-nat6
TITLE:=IPv6 NAT targets
KCONFIG:=$(KCONFIG_IPT_NAT6)