aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netdevices.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-04 06:10:03 +0000
committerJohn Crispin <john@openwrt.org>2015-04-04 06:10:03 +0000
commit0b44b593a78e39b2843c80a1a2d58670a0d5e76f (patch)
tree781c15115bda66197379258605aae927ba19ff93 /package/kernel/linux/modules/netdevices.mk
parent0e78550030b336016ca3736062a3fea4ce174bf3 (diff)
downloadupstream-0b44b593a78e39b2843c80a1a2d58670a0d5e76f.tar.gz
upstream-0b44b593a78e39b2843c80a1a2d58670a0d5e76f.tar.bz2
upstream-0b44b593a78e39b2843c80a1a2d58670a0d5e76f.zip
kernel: switch to upstream
This driver is upstream since 2012 (commit: a8e510f682f), so switch to it and remove own sources. Also place it under "Network Devices" menu together with other phy drivers. Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> SVN-Revision: 45269
Diffstat (limited to 'package/kernel/linux/modules/netdevices.mk')
-rw-r--r--package/kernel/linux/modules/netdevices.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index dd8692a8e6..450899878a 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -810,3 +810,20 @@ define KernelPackage/vmxnet3/description
endef
$(eval $(call KernelPackage,vmxnet3))
+
+
+define KernelPackage/spi-ks8995
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Micrel/Kendin KS8995 Ethernet switch control
+ FILES:=$(LINUX_DIR)/drivers/net/phy/spi_ks8995.ko
+ KCONFIG:=CONFIG_MICREL_KS8995MA \
+ CONFIG_SPI=y \
+ CONFIG_SPI_MASTER=y
+ AUTOLOAD:=$(call AutoLoad,50,spi_ks8995)
+endef
+
+define KernelPackage/spi-ks8995/description
+ Kernel module for Micrel/Kendin KS8995 ethernet switch
+endef
+
+$(eval $(call KernelPackage,spi-ks8995))