aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netdevices.mk
diff options
context:
space:
mode:
authorSteffen Förster <steffen@chemnitz.freifunk.net>2018-07-08 22:18:07 +0200
committerJohn Crispin <john@phrozen.org>2018-07-16 15:12:18 +0200
commit1ef65ceeafa9f1d5f4c0e0fe851907a4c8afa483 (patch)
tree0b0d312df540c48a469a0dd527680fc096c633a7 /package/kernel/linux/modules/netdevices.mk
parent09d794ab928bb8a02e1d296e32cc8fbac7085049 (diff)
downloadupstream-1ef65ceeafa9f1d5f4c0e0fe851907a4c8afa483.tar.gz
upstream-1ef65ceeafa9f1d5f4c0e0fe851907a4c8afa483.tar.bz2
upstream-1ef65ceeafa9f1d5f4c0e0fe851907a4c8afa483.zip
kernel: insmod phy-broadcom module during preinit
Some HP Thin clients use the broadcom nextreme chip as integrated NIC. It is connected via PCI express and will only be found automatically if phy-broadcom is loaded before tg3. This small change makes the thin client usable for Freifunk with gluon out of the box. Signed-off-by: Steffen Förster <steffen@chemnitz.freifunk.net>
Diffstat (limited to 'package/kernel/linux/modules/netdevices.mk')
-rw-r--r--package/kernel/linux/modules/netdevices.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 647b1894fe..6d05d6fcd0 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -169,7 +169,7 @@ define KernelPackage/phy-broadcom
KCONFIG:=CONFIG_BROADCOM_PHY
DEPENDS:=+kmod-libphy +kmod-phylib-broadcom
FILES:=$(LINUX_DIR)/drivers/net/phy/broadcom.ko
- AUTOLOAD:=$(call AutoLoad,18,broadcom)
+ AUTOLOAD:=$(call AutoLoad,18,broadcom,1)
endef
define KernelPackage/phy-broadcom/description